How do I uninstall odrive?

faq

#1

How do I uninstall odrive from my computer?


Completely remove odrive (from contect menu) OSX
Impossible to remove odrive from explorer
Removing odrive
How to restore all local files and safely remove Odrive?
Folder Re-Sync'ing
Uninstall incomplete
Uninstall odrive finder extension
Odrive icon remains after removal from OS X
Odrive icon remains after removal from OS X
Odrive icon remains after removal from OS X
"Unexpected error" and "Unable to read system data"
Undo Deletions and this must be 15 characters
#2

Windows :

  1. Exit odrive
  2. Uninstall odrive using the standard windows uninstall method (add/remove programs).

The default odrive folder will be renamed to odrive_backup_[current date and time] as a backup.


MacOS:
Please follow the steps outlined below:

  1. Exit odrive.

  2. Open a terminal session (type “terminal” in Spotlight search):

  3. Run the following command in the terminal session (copy & paste the entire thing into terminal and hit the Enter key):

cd "$HOME" && rm -r ".odrive" && killall Finder;mv "odrive" "odrive_$(date +%Y-%m-%d:%H:%M:%S)";cd "/Applications" && sudo rm -r "odrive.app";cd "/Library/Application Support" && if [ -d "odrive" ]; then sudo rm -r "odrive"; fi; cd "$HOME";

This will:

  • delete ~/.odrive program folder
  • restart Finder (to release the Finder extension)
  • rename the default odrive folder in your home folder, if it exists, to odrive_[current date and time]. You will find this in the root of your home folder.
  • delete /Applications/odrive.app
  • delete /Library/Application Support/odrive (This is a legacy folder and may not exist on your system).

The command will ask for your password as part of cleanup. This is to ensure that proper permissions are available when removing the odrive folders from /Applications and /Library/Application Support


Problem While Uninstalling - App not Fully Removed
What circumstances will cause odrive to delete files in the cloud?
Odrive does not upload files & popup menu not working on macOS Sierra
Corrupted Sync Database?
oDrive stoped, and won't start
Unable to sync - already an odrive folder
Unsync and Delete odrive - All Files Are .Cloud
Unable to log in with Mac desktop client - Duplicate Account Issue
Odrive not starting. "legacy db" access issue
Wrong Browser, Connected to wrong account, can't disconnect
Issue with moving odrive folder
HipChat linked folders won't sync - "Unexpected Error" - Ideas?
Odrive unable to sync. This file is not inside an odrive folder
Can no longer login to app, things going a bit crazy!
SFTP sync issues
Uninstall ODrive from Mac
Remove Many (6+) Odrive Finder Extensions, not running Odrive
OSX Sierra folder content randomly does not sync
Can't get around - Waiting changes will auto retry
Excessive Memory Usage: OSX El Capitan 10.11
#4

A post was merged into an existing topic: Odrive quits after a few seconds OSX 10.12


#5

Linux instructions would be nice too. Is it really just deleting folders?


#6

Hi @p_ingram3541,
For Agent, as you said, it is just a matter of removing the folders you made during install, if you were installing using the usage guide instructions here:

Those folders will be:
[User Home Folder]/.odrive-agent
[User Home Folder]/odrive-agent-mount


#7

Thanks for the clarification Tony. I figured out my issue was installing partially as su which was resulting in never seeing any .cloudf folders to sync. Once I changed the location of the sync folder (under my daily driver user) everything is working.


#8

2 posts were split to a new topic: What circumstances will cause odrive to delete files in the cloud?


#9

Hello,

This worked for me. But it also created a folder with quotes in the same directory as Applications, Library, etc. And the path looks like this:
"/Users/[Username]

The timestamp when I ran the command matches with the folder creation.

Is this normal? Do I need this folder?

Thanks.


#10

Hi @digiform,
Can you post a picture of what you are seeing?
What is inside of that folder?

The script doesn’t create any folders and renames only one (the odrive folder). It is not expected that a folder like you describe is created.

The script actually tries to be as precise and safe as possible, which is why the && are used, and there are no slashes, wildcards, or environment variables used within the remove or move actions.


#11

Hey Tony —

I followed these directions but get an error in Terminal: http://cozy.es/h5Flc4+

Help?


#12

Hi @lee3,
That error is okay. Newer versions of the application do not have that folder.


#13

I have tried this uninstall instruction multiple times on my Mac but it doesn’t work. I juts keep getting a “No such file or directory” Any suggestions???

Here is the info from terminal:

Names-MacBook-Pro-2:~ myname$ cd “$HOME” && rm -r “.odrive” && killall Finder;mv “odrive” “odrive_$(date +%Y-%m-%d:%H:%M:%S)”;cd “/Applications” && sudo rm -r “odrive.app”;cd “/Library/Application Support” && if [ -d “odrive” ]; then sudo rm -r “odrive”; fi; cd “$HOME”

mv: rename odrive to odrive_2018-12-15:09:16:56: No such file or directory

Password:

rm: odrive.app: No such file or directory


#14

Hi @uunans,
If you have performed this multiple times then I would expect to see these errors, since the folders have already been moved or removed.

What are you seeing that is still existing/running?


#15

Sorry, that wasn’t clear! I meant I have tried that multiple times and ODrive is still on my computer!


#16

Hi @uunans,

The script basically removes or renames the three folders that are associated with odrive:

  • ~/.odrive program folder is removed
  • The default odrive folder at ~/odrive is renamed to odrive_[current date and time].
  • /Applications/odrive.app folder is removed

Do you still see any of those folders? You can check by running these commands from the same terminal window you already have open:

  • ls ~/.odrive
  • ls ~/odrive
  • ls /Applications/odrive.app

The odrive Finder extension is in the ~/.odrive folder. Once that is deleted, Finder needs to be restarted for it to remove the extension from memory. The script should be doing all of these things, but it sounds like it may not be for your system, for some reason.


#17

all good now . I found 2 stubborn odrive files when I used the ls ~/.odrive. Thank you for your help