HipChat linked folders won't sync - "Unexpected Error" - Ideas?


#5

Hey Tony,

If I changed my Hipchat Password could that have caused it?

Here is what I see in the Web Client:

Attached

Thanks! - Ryan


#6

Hi @ryan,
I would expect a different error for the password change (session error). Since you can actually browse around a bit, it seems like it is something else.
Are any folders listing anything?
What about your own user folder?


#7

Hey Tony,

No. None of the folders are listing anything.

They all say, “This folder is empty”

Ideas?..

My Hipchat “User Folder” inside of oDrive - it also says “empty.”


#8

Hi @ryan,
Something definitely seems screwy.

Can you try unlinking and relinking hipchat? This will remove the folder from the desktop client, so make sure you don’t have anything in there that isn’t already uploaded.

After relinking, let me know if the behavior has improved.


#9

Hey Tony,

I “Unlinked” HipChat and then “Re-Linked” Hipchat.

In doing so, it removed the HipChat folder from oDrive - then added it back. And it did sync the Rooms and User Folders. But inside those folders, there is nothing. It did not download the files that are present in those Rooms, etc… And in the web client, when I go to the Room or User Folders, I still get that same notice, “This Folder is Empty.”

Ideas?


#10

Hi @ryan,
It sounds like maybe something was changed on your company Hipchat account, since you can authenticate correctly and pull a list of the Users and Rooms.

Even your own User folder is empty, correct?

Do you have any other colleagues that use odrive with Hipchat? If so, are they seeing the same problem?


#11

No, I don’t have other colleagues that use the integration.

What can I do?.. I didn’t change anything in the company HipChat account…

But even if something got changed? - what could it be?

Thanks Tony!

-RYAN


#12

Hi @ryan,
Good questions. I’m not actually sure in this case. I cannot reproduce the issue you are seeing.

When you try to link Hipchat, can you take some screenshots of the flow you go through? I would be most interested in seeing the screen where you confirm account access the permissions listed are.
Can you also send a diagnostic from the odrive menu after linking and trying to access the folders on your desktop?


#13

Hey Tony,

Sorry for the delay in getting this done. But here is that screenshot.

And I just sent the diagnostic as well.

Ideas? Thanks.

-RYAN


#14

I also tried uninstalling oDrive. Logging out.

Then creating a new account with my Dropbox Login, rather than my FB login.

Then I re-linked. And… same problem.

hmm, ideas?


#15

Hi @ryan3,
This is so strange.

Looking at the diagnostic, you can see all of the rooms, but Hipchat is not returning any content for them.

When you click on “Integrations”, select “Global (all rooms)” and then click on the “Installed” button next to the room selector, do you see odrive listed?

When you uninstalled, did you follow these instructions here? How do I uninstall odrive?

Can you create a Space against one of the rooms you know should have content (right-click “Share Storage”) and invite support@odrive.com to it? I may be able to debug further that way.


#16

— “but Hipchat is not returning any content for them.”

that’s correct. “This folder is empty”

— When you click on “Integrations”, select “Global (all rooms)” and then click on the “Installed” button next to the room selector, do you see odrive listed?

Yes, oDrive is listed.

Also, just created that Space and sent that invite to: support@odrive.com

Thanks for your help,

-RYAN


#17

Hi @ryan3,
I took a look and it just looks like Hipchat is returning an empty response when we ask for the listing. I even tried an upload, and the actual upload returns a “success” response, but then when we go to look for it its not listed.

I took a deeper look at the integration code, and to list the items, we are making a call to Hipchat’s “history”. It is possible that if the history has been disabled in the “Group Admin”->Preferences then this could result in no history being returned.

If you view a room’s history at https://youraccountname.hipchat.com/history/room/room# do you see things listed?
If you go to the history of the Room that you shared with me, do you see the files that I uploaded there? What about in the normal Hipchat chat interface for that Room?


#18

Hey Tony,

Here is a screenshot of the History, from the admin panel: (for 8/30)

Then to see the actual links/files in that room, I need to launch the web app:

Does this help at all - ideas?

Thanks!

-RYAN


#19

Here is the screenshot from yesterday’s History:


#20

Thanks @ryan3,
We can see the uploads made it, so general permissions isn’t an issue.

This one has me a bit stumped. Maybe we can get Hipchat involved to see if we can figure out why we can pull the listing of these rooms.

Do you think you can reach out to them here and then loop me in?
https://id.atlassian.com/login?continue=https://support.atlassian.com/contact/


#21

Thanks Tony - I submitted a Support ticket. And included you on the ticket.

-RYAN


#22

Thanks @ryan3,
I didn’t receive an e-mail yet, but I’ll keep a lookout for their response.


#23

Hey Tony, thanks.

I just forwarded you their response from the Support Ticket:

Get it?

-RYAN


#24

Hi @ryan3,
I see it now. Can you explain the situation to them?

Essentially, what we are seeing is that the integration is able to list the rooms, we can upload files, but we are not receiving any items in our history request for your account:
https://www.hipchat.com/docs/apiv2/method/view_room_history

Our own testing for other HipChat accounts does not show this problem, and the room listings are returned as expected. It seems to be something specific with your account. Also let them know that this was working fine a few weeks ago and suddenly stopped. There were no changes on the odrive integration during this time.