Right-click won't work on odrive icon in icon tray (Windows 10 Anniversary)

Odrive Premium user here (fwiw, in terms of technical stuff).

It does work for other apps, but at some point in the syncing process, it won’t do anything if I right click the icon.

Hi @slowdriver,
Are you saying the odrive tray menu becomes unresponsive when right or left-clicking on it?
If so, when this does happen, do you know if odrive is in the process of syncing? Are you currently performing any bulk actions within odrive?
Does the condition clear up, or does it remain unresponsive?


I don’t know, as some files don’t have an icon, but others do. I’d have to have to track a lot of files.

Yes. I am/was in the process of such.

I haven’t waited long enough, but if I do, I’ll let you know.

Ok, so I’ve had it on for at least 4 hours and the right-click function won’t work.

Thanks for the update. The menu should not lock-up like this, in any case.

If you look at the odrive processes in the Task Manager, are they consuming CPU and fluctuating? Do you see any icon overlay changes when observing the odrive folders?

We can also use the CLI to give us a status view of what is going on. It may provide a better way for you to consume this information.

You can copy and paste these commands into a command prompt on windows to run.

This first command will download the odrive CLI for windows:

powershell -command "& {$comm_bin=\"$HOME\.odrive\common\bin\";$o_cli_bin=\"$comm_bin\odrive.exe\";(New-Object System.Net.WebClient).DownloadFile(\"https://dl.odrive.com/odrivecli-win\", \"$comm_bin\oc.zip\");$shl=new-object -com shell.application; $shl.namespace(\"$comm_bin\").copyhere($shl.namespace(\"$comm_bin\oc.zip\").items(),0x10);del \"$comm_bin\oc.zip\";}"

This second command will query the odrive desktop status:

powershell -command "& {$comm_bin=\"$HOME\.odrive\common\bin\";$o_cli_bin=\"$comm_bin\odrive.exe\";$(& \"$o_cli_bin\" status);}"

It doesn’t fluctuate in Task Manager, but stays at the top, so it might be fluctuating in positions not filled by other apps, if that makes sense.

I used the first command to download it…not sure how to “install” it.

Hmm. So It’s been running for a couple of hours and I haven’t had this problem yet. I think it occurs when new files are added to it.

Ok, so I stopped the sync as the last action (before that, I tried emptying the trash as only received an error with not being able to delete some folder) I’ve had with the odrive app, and then it stopped being clickable. It turns out that it’s not uploading anything. I blacked out my email, fwiw.


It looks like you have a lot of files in waiting. I am guessing the UI is having trouble refreshing with all of those items in the queue. I will circle back with the team on this.

If you stopped sync then it will not upload anything until you restart it again, although that will be difficult to do from the tray menu if its not responding…

What may be best, for now, is to shutdown odrive, then restart and use the CLI to monitor the status. To do that you can do the following:

  • Run this command from the command prompt to shutdown and exit odrive:

powershell -command "& {$comm_bin=\"$HOME\.odrive\common\bin\";$o_cli_bin=\"$comm_bin\odrive.exe\";$(& \"$o_cli_bin\" shutdown);}"

  • Start odrive again

  • Run this command to monitor odrive’s status/progress. It will refresh every 10 seconds:

powershell -command "& {$comm_bin=\"$HOME\.odrive\common\bin\";$o_cli_bin=\"$comm_bin\odrive.exe\";while(1){$(& \"$o_cli_bin\" status);start-sleep -seconds 10;clear;}}"

See if odrive continues to make progress, despite the tray menu possibly being unresponsive.


facepalm you’re right.

Ok, thank you. I’ll try that out!

1 Like

I tried the last command as I decided against shutting down odrive (restarting it technically fixes it, until at some point it breaks). It says that it’s still uploading, so it must be working.

Thanks for the update.

How did you re-enable sync without access to the odrive tray menu?

In other words, what I did was:

  1. (didn’t stop sync) noticed that the notification tray icon was unresponsive
  2. Used the last command that you have (that refreshes every 10 seconds).
  3. Noticed that files were still uploading

Thanks for the update. If you get a chance, let me know if the menu behaves normally after things settle.

1 Like

A post was merged into an existing topic: Problem unsyncing files and folders

Having same problem. When I right click the odrive icon in the icon tray, nothing happens. When I click on the odrive app in Windows 10, nothing happens. The app is still syncing, and I can right click on a folder and initiate sync. I am just unable to access any odrive options like change location, etc.

Hi @REG,
Are you currently performing a bulk operation like upload?

What do you see when you run the commands in this post?

Excuse my ignorance if I did this wrong. I went to the C:\ and executed the command. Here is what was returned after executing the second command, the first command to download the odrive CLI for windows did not respond with anything. No, odrive is not performing any updates.

C:>powershell -command “& {$comm_bin=”$HOME.odrive\common\bin";$o_cli_bin="$comm_bin\odrive.exe";$(& “$o_cli_bin” status);}"
& : The term ‘C:\Users\Ronald.odrive\common\bin\odrive.exe’ is not recognized
as the name of a cmdlet, function, script file, or operable program. Check the
spelling of the name, or if a path was included, verify that the path is
correct and try again.
At line:1 char:79

  • … ommon\bin";$o_cli_bin="$comm_bin\odrive.exe";$(& “$o_cli_bin” status) …
  •                                                  ~~~~~~~~~~~~
    • CategoryInfo : ObjectNotFound: (C:\Users\Ronald…\bin\odrive.e
      xe:String) [], CommandNotFoundException
    • FullyQualifiedErrorId : CommandNotFoundException


Yes, it is consuming CPU in the task manager.

It looks like it wasn’t downloaded properly for some reason. Can you try this command? It will output a little more info while it does its thing:

powershell -command "& {$comm_bin=\"$HOME\.odrive\common\bin\";$o_cli_bin=\"$comm_bin\odrive.exe\";echo \"Downloading CLI\";(New-Object System.Net.WebClient).DownloadFile(\"https://dl.odrive.com/odrivecli-win\", \"$comm_bin\oc.zip\");$shl=new-object -com shell.application;echo \"Extracting CLI\";$shl.namespace(\"$comm_bin\").copyhere($shl.namespace(\"$comm_bin\oc.zip\").items(),0x10);del \"$comm_bin\oc.zip\";echo \"Done!\";ls \"$comm_bin\";}"

Then you would run this again:
powershell -command "& {$comm_bin=\"$HOME\.odrive\common\bin\";$o_cli_bin=\"$comm_bin\odrive.exe\";$(& \"$o_cli_bin\" status);}"

Also, not running anniversary edition, just running version 1511 build 10586.589