Odrive will not open in Windows on PC

Seemingly all of a sudden, my odrive refuses to launch or even run in Windows. When I try to open the app, nothing happens. I’ve tried to ‘run as administrator’ unsuccessfully as well. I have uninstalled following instructions found in the odrive Forum…rebooted my computer…and reinstalled odrive several times, all unsuccessful. Any ideas or suggestions to get the odrive sync to work properly again?

Hi @miranda,
Sorry you are running into trouble here. Can you please follow the instructions here so that we can see if the app is spitting anything out before it dies?

1.Open a command prompt (cmd)
2.Copy and paste the following and hit enter:

cd “%userprofile%\.odrive\bin” && dir

3.The above command will list at least one four digit directory (like 5453). You will then want to use that number in the following command:


make sure you use whatever number you have, if it is not 5453

This will launch odrive. Please provide a screenshot of what you see in the command window after that.


I think I have the same problem. I installed odrive but it does not show in file explorer nor can I open it.

Here is the information that was returned.

Hi @barb

From the screenshot it actually looks like odrive is running. Do you see an odrive tray icon in your tray menu?

Hi Tony,

Unfortunately, odrive did not successfully run after that command. Here is a screen shot showing that: “’.\5453\odriveapp.exe’ is not recognized as an internal or external command,
operable program or batch file.”

Help! :slight_smile:

Hi @miranda,
Can you show the output from this command?
cd "%userprofile%\\.odrive\bin\5453" && dir /w

It seems like maybe the auto upgrade did not complete successfully, although it is difficult to say.

We can try to move the .odrive directory out of the way and have it be recreated on the next launch. To do this enter the following command:
powershell -command " & {ren \"$HOME\\.odrive\" \"$HOME\dot_odrive_bak\"}"

Then try launching odrive normally.


Hi @Tony,

Here is the output from the command “cd “%userprofile%.odrive\bin\5453” && dir /w”


Also attached is the second command you provided to move the .odrive directory out of the way. It says .odrive doesn’t exist in that location, but in part of the screen shot you’ll see that it actually does. odrive simply will not open.

Hi @miranda,
Sorry about the command, the forum ate one of my slashes. Try this instead. It will “reset” the bin directory, which seems to be incomplete, and then start odrive:

powershell -command " & {Stop-Process -erroraction silentlycontinue -processname odriveapp; ren \"$HOME\.odrive\bin\" \"$HOME\.odrive\bin_bak\";del \"$HOME\.odrive\version\";Start-Process -NoNewWindow \"$env:programfiles\odrive\odrive.exe\";sleep 30;del -recurse \"$HOME\.odrive\bin_bak\"}"

THAT WORKED! Thank you so much.


Hi Miranda.
I have followed the previous instructions but cannot launch odrive from the system tray.

Hi @martinpacehuahin

Please copy and paste this into a command prompt and run it. Paste the output here:
powershell -command " & {$dot_odrive=\"$HOME\.odrive\";$curver = $(dir \"$dot_odrive\bin\" -ad | sort LastWriteTime | select Name -ExpandProperty Name -last 1); dir \"$dot_odrive\bin\"; & \"$dot_odrive\bin\$curver\odriveapp.exe\";}"


Hi Tony.
Here is the output

Microsoft Windows [Version 10.0.14379]
© 2016 Microsoft Corporation. All rights reserved.

C:\Users\WINDOWS8.1.1>powershell -command " & {$dot_odrive="$HOME.odrive";$curver = $(dir “$dot_odrive\bin” -ad | sort LastWriteTime | select Name -ExpandProperty Name -last 1); dir “$dot_odrive\bin”; & “$dot_odrive\bin$curver\odriveapp.exe”;}"

Directory: C:\Users\WINDOWS8.1.1\.odrive\bin

Mode LastWriteTime Length Name

d----- 04/07/2016 17:27 5453

Hi @martinpacehuahin,
The “C:\Users\WINDOW~1.1\ODRIVE~1\bin\5453\qml” indicates that odriveapp is running.

Do you see the icon in the windows taskbar? Are you certain it is not running?

Hi Tony. It is in the windows taskbar but the only options are open and unpin from taskbar. If I click open, nothing happens. Whaen I try to open it from the start menu, nothing happens. Looking at your website, I should get a long list of options when right clicking the icon, including move to a new drive?

Make sure you are looking in the tray icon area, which Windows likes to hide. Clicking on the “^” will pop-up and expose the hidden items.

Hi Tony. It is not showing in the tray icon area.

After running the command in this post: Odrive will not open in Windows on PC was there anything shown after the:

Can you run that again and provide a screenshot of that window? I’m just trying to figure out where things are going wrong.

Was odrive ever working for you, or has it been this way since you initially installed?

We can also try to start from scratch by executing the following command from a cmd prompt:

powershell -command " & {kill -erroraction silentlycontinue -n odriveapp; sleep 5; ren -erroraction silentlycontinue \"$HOME\.odrive\" \"$HOME\dot_odrive_bak__$(get-date -f yyyy-MM-dd-hh-mm-ss)\";ren -erroraction silentlycontinue \"$HOME\odrive\" \"$HOME\odrive_bak_$(get-date -f yyyy-MM-dd-hh-mm-ss)\";Start-Process -NoNewWindow \"$env:programfiles\odrive\odrive.exe\";}"

Hi Tony.
I executed the command to start from scratch and now it seems to be working. Thanks. PS. There was no extension to the output after 5453/qml"?

Hmm… well I’m glad things are working now. Not sure what the issues was, specifically, but just let us know if it happens again.


Not sure either but thanks Tony. It is working now.

1 Like