ODrive will not launch in windows

As before I am still unable to get odrive to launch correctly when I click the icon. I have to go into the odrive folder and launch it from in there and it opens a command window and then odrive.

Exception in thread Thread-1:
Traceback (most recent call last):
File “C:\hudson\workspace\Odrive_Win_Master_Build\stage\artifacts\build\odrive
app\WinOdriveApp\out00-PYZ.pyz\threading”, line 801, in __bootstrap_inner
File “C:\hudson\workspace\Odrive_Win_Master_Build\stage\artifacts\build\odrive
app\WinOdriveApp\out00-PYZ.pyz\mixpanel_async.async_buffered_consumer”, line 36,
in run
File “C:\hudson\workspace\Odrive_Win_Master_Build\stage\artifacts\build\odrive
app\WinOdriveApp\out00-PYZ.pyz\mixpanel_async.async_buffered_consumer”, line 255
, in _sync_flush
File “C:\hudson\workspace\Odrive_Win_Master_Build\stage\artifacts\build\odrive
app\WinOdriveApp\out00-PYZ.pyz\mixpanel”, line 433, in _flush_endpoint
File “C:\hudson\workspace\Odrive_Win_Master_Build\stage\artifacts\build\odrive
app\WinOdriveApp\out00-PYZ.pyz\mixpanel”, line 335, in send
File "C:\hudson\workspace\Odrive_Win_Master_Build\stage\artifacts\build\odrive

Is the output in the command window, I’d guess maybe a permissions issue but even launching with admin I get the same problem. Been like this for months now and I thought I would try once more to fix it before using something else.

Hi Riffy, can you send me the diagnostics from the system tray menu? Hopefully that will have some more detailed info. Thanks!

Okay hit the button to send it over. Does it create a file I can open myself and look at?

Hi Riffy,

Thanks, I got the log dump and will see what we can find. Does this only happen on start up, or is the app dying during normal use, and are you running any ant-virus software as well?

It just won’t start unless I run it from inside the folder. Once it’s up it sometimes works and sometimes just sits there doing nothing even when I try to make it. It may have been stuck trying to do that whole converting thing when you did the last big update is how long I’ve been having problems.

Viri stuff is just windows defender or whatever they renamed it to. Could you maybe answer one simple question, did you guys ever install a throttle limit into the program? Last time I ran it comcast got pissy when I moved a few terabytes in a month.

Can you check in Defender, and under settings add the odrive app to Excluded processes to make sure it is not being blocked there, or even try disabling it all together to see if that helps?

We have definitely refined and optimized the upload, but do not have a built in throttle as that is a huge undertaking. There are quite a few third party apps that do allow you to limit the upload bandwidth of individual programs such as net balancer (they do have a free version I believe) that allows for custom settings per program.

I don’t see odrive in the firewall settings which is a bit odd. But it seems work manually even if not in the firewall allowed list so I don’t see why that would stop the launch of the program and shouldn’t it just launch and say no connection? Well I can just go add it anyway just odd windows doesn’t do a popup for it. Which exe should I direct it at?

The main location for the exe is C:\Program FIles\odrive\odrive.exe - be sure you add this exception to Defender, it does not seem like there is an issue with the firewall blocking it, but it can’t hurt to add that exception.

It was renamed I forgot, windows calls it microsoft security essentials now. But I will add it but I have never had to add anything to that list before so I’d like to know why windows would block you as malicious software.

Adding it didn’t let odrive launch.

Alrighty then! Would you mind taking a look at the event logs, see if odrive app or the exe are kicking off any OS level errors?

Control Panel > System & Security > Administrative Tools, and then double-clicking Event Viewer

Expand Windows Logs and click Application, you can search for odrive by clicking “find” in the right hand window and entering odrive

Yeah nothing is listed in it. Last thing for odrive was me uninstalling and reinstalling it this morning.

Hi Riffy, we are discussing ways to troubleshoot with engineering and will follow up, thanks for your patience while we work through this!

Hi Riffy, can you try this via admin command prompt?

Open cmd with admin rights and navigate to C:\Program Files\odrive and from there run this command and attach the log that gets created on your desktop: “odrive.exe -v > %userprofile%\Desktop\odrivelog.txt” Thanks!

This was a previous message from the old forum.

Just migrating the information over to here.

I just started experiencing this a few weeks ago – odrive will not start on my windows 10 machine. I’ve searched the forums and tried all of the options suggested, the only way that it works is if I run it from the odriveapp.exe which has the command prompt running the whole time.

Any other ideas? I have no additional anti-virus running, so its not that blocking it. And I dont see any services running either in the background unless I’m not recognizing it.

Thanks in advance guys! It works perfectly on my other PC’s – its just this one specifically.

Roop Rahal
What’s the full path for odriveapp.exe?


Roop Rahal
any spaces or weird chars etc in the username?

yes – its my name – so FirstName MiddleInitial. LastName
It was working previously though and the username hasnt changed – would that have changed recently?

Roop Rahal
i think its an issue with a space in the name possibly then, ill look into it and get a fix out as soon as possible

Ok awesome! Thanks in advance!

Thanks for “migrating” :wink:

Can you try running the main odrive exe (what we call the launcher), from the command line? It is located in program files. I am hoping it might say something about why it is having an issue launching odriveapp.
C:\Program Files\odrive\odrive.exe

Tried doing that and I get the “thinking” wheel on my mouse cursor for just a second and then nothing else. Is there a log somewhere that I can look at maybe?

Thanks for the assist! :slightly_smiling:

i tested the space in the username issue and that is not an issue, it should launch, maybe check process manager and kill all odrive processes and try again

The log file :slightly_smiling:

[INFO] 2016-01-28 17:56:25,338: Product home path: C:\Users\xxxxusernamexxxx.odrive
[INFO] 2016-01-28 17:56:25,338: name: app.tar.gz, url: local, sha256: 6be57d33703acac9f094f7ce581497ffe37ab781150e7737cbea05b6abf78ec6, destination: C:\Users\xxxxusernamexxxx.odrive, version: 4816, deleteIfExist: [u’C:\\Users\\xxxxusernamexxxx\\.odrive\\bin\\4816’], miscExtractionPoint: C:\Users\xxxxusernamexxxx.odrive\bin\4816, noExtract: False
[INFO] 2016-01-28 17:56:25,338: name: common.tar.gz, url: local, sha256: 81a3970344a35ae2296f46d259c9cb1ab58e66772663d8f5b7e565063ae116bb, destination: C:\Users\xxxxusernamexxxx.odrive\common\bin, version: 4816, deleteIfExist: [u’C:\\Users\\xxxxusernamexxxx\\.odrive\\common\\bin’], miscExtractionPoint: None, noExtract: False
[INFO] 2016-01-28 17:56:25,338: Launching C:\Users\xxxxusernamexxxx.odrive\bin\4816\odriveapp.exe
[ERROR] 2016-01-28 17:56:27,726: Failed to launch C:\Users\xxxxusernamexxxx.odrive\bin\4816\odriveapp.exe

There arent any processes running at least that I recognize to close.

I messed up the log paths while masking the username. Sorry about that.