ODrive will not launch in windows

Thanks. We need to figure out how to better determine what is happening here. Is it possible for you to take a quick scan through the Windows 10 event logs to see if anything pops in them when you launch?

couple of things i can think of off the top of my head are permissions issues with the exe, C:\Users\xxxxusernamexxxx.odrive\bin\4816\odriveapp.exe doesn’t exists - you mentioned you start the app from C:\Users\xxxxxusername.odrive\bin\4803\odriveapp.exe, wondering if its trying to launch the wrong version? or some unicode chars in the username…

Yea the previous link I gave you was from before I removed odrive completely and reinstalled with the newest setup file. The newest setup file is running out of 4816 now.

Just added permissions to both apps, the launcher exe and the odriveapp exe - added full permissions for Users and Everyone - same result.

Thanks for the clarification. We are discussing this internally. Were you able to take a peek at the Windows event logs to see if anything is popping for this issue, when it happens?

yea - not entirely sure where to look within the event logs - nothing stands out though at least under the error event types.

Yeah, I’m not sure what to look for either, really. I figure a quick scan through the the system and application logs after triggering this might show something, but it sounds like thats a no-go.

Yea I didnt see anything popping up immediately when launching - i DID find an entry in the log for odrive, but it wasnt during any of the times that I attempted to launch - the times were from earlier.

The application \Device\HarddiskVolume2\Users\xxxusernamexxx.odrive\bin\current\odriveapp.exe with process id 6468 stopped the removal or ejection for the device PCI\VEN_8086&DEV_1C02&SUBSYS_2ADA103C&REV_05\3&11583659&0&FA

A post was merged into an existing topic: ODrive will not launch in windows 7

I am experiencing this as well. My username has a space in it. If I run the odriveapp.exe file from from it’s location it will run, but it won’t start from the launcher.

[INFO] 2016-02-02 21:44:37,693: Product home path: C:\Users\Riffy Divine.odrive-divine\desktop\odrivelog1.txt
[INFO] 2016-02-02 21:44:37,703: Verifying misc.tar.gz
[INFO] 2016-02-02 21:44:37,921: Moving misc.tar.gz into C:\Users\Riffy Divine.odrive-divine\desktop\odrivelog1.txt\common\misc
[INFO] 2016-02-02 21:44:37,977: Dropping version file into C:\Users\Riffy Divine.odrive-divine\desktop\odrivelog1.txt\common\misc\version with version 15
[INFO] 2016-02-02 21:44:37,979: name: app.tar.gz, url: local, sha256: 389f969db8093d92353c4de3f0dcef457c3b3f53604ce7dedeae00a94e09c793, destination: C:\Users\Riffy Divine.odrive-divine\desktop\odrivelog1.txt, version: 4828, deleteIfExist: [u’C:\\Users\\Riffy Divine\\.odrive-divine\\desktop\\odrivelog1.txt\\bin\\4828’], miscExtractionPoint: C:\Users\Riffy Divine.odrive-divine\desktop\odrivelog1.txt\bin\4828, noExtract: False
[INFO] 2016-02-02 21:44:37,979: Verifying app.tar.gz
[INFO] 2016-02-02 21:44:38,066: Extracting app.tar.gz into C:\Users\Riffy Divine.odrive-divine\desktop\odrivelog1.txt
[INFO] 2016-02-02 21:44:40,171: Extracting misc for bundle app.tar.gz
[INFO] 2016-02-02 21:44:43,348: Dropping version file into C:\Users\Riffy Divine.odrive-divine\desktop\odrivelog1.txt\version with version 4828
[INFO] 2016-02-02 21:44:43,348: name: common.tar.gz, url: local, sha256: e4fe9c638e2eb17b260ecf1f79524675f4497204c183ea48f1df1dec8a1d0817, destination: C:\Users\Riffy Divine.odrive-divine\desktop\odrivelog1.txt\common\bin, version: 4828, deleteIfExist: [u’C:\\Users\\Riffy Divine\\.odrive-divine\\desktop\\odrivelog1.txt\\common\\bin’], miscExtractionPoint: None, noExtract: False
[INFO] 2016-02-02 21:44:43,348: Verifying common.tar.gz
[INFO] 2016-02-02 21:44:43,349: Extracting common.tar.gz into C:\Users\Riffy Divine.odrive-divine\desktop\odrivelog1.txt\common\bin
[INFO] 2016-02-02 21:44:43,365: Dropping version file into C:\Users\Riffy Divine.odrive-divine\desktop\odrivelog1.txt\common\bin\version with version 4828
[INFO] 2016-02-02 21:44:43,367: Launching C:\Users\Riffy Divine.odrive-divine\desktop\odrivelog1.txt\bin\4828\odriveapp.exe
[ERROR] 2016-02-02 21:44:45,493: Failed to launch C:\Users\Riffy Divine.odrive-divine\desktop\odrivelog1.txt\bin\4828\odriveapp.exe

Here you go. Seems it didn’t spit it out to the desktop like it should have but I found it all the same.

I also ran odrive.exe -v, here are the contents of the log file:

Starting launcher with verbose output…
No product argument was passed in. Attempting to find product.conf…
Using path C:\PROGRA~1\odrive\product.conf…
Using C:\Users\Michael Angelo.odrive as the installed folder path…
Attempting to mark the installed folder path as hidden…
Writing the product.conf file at C:\Users\Michael Angelo.odrive…
Reading the version number from the version file…
Attempting to read systemAlertRoom from config…
Setting up diagnostics for buildNo: 4828, productName: prod, systemAlertRoom: 1358891
Creating launcher object…
Checking if another odrive process is running again to reduce the chances of a race condition…
Launching…
Launch succeeded!

Even though it says launch succeeded, nothing comes up.

Thanks @Riffy_Divine and @DocGrim. There are some odd results int the text you posted, so can you run it one more time this way?

Open up a command prompt and copy and paste this in, including the quotes:
“%programfiles%\odrive\odrive.exe” -v > “%userprofile%\Desktop\odrivelog.txt”

Once this is done, please attach both odrivelog.txt, which should be on your Desktop and the odrive.log in the .odrive directory in your user profile directory (its hidden so make sure to show hidden files). You can attach files by using the button on the tool bar at the top ^.

Thanks!

Unfortunately, the file uploader on these forums only allow images. Here are links to the both of the files:

odrivelog.txt

odrive.log

Thanks @DocGrim. I added support for .txt and .log in the forum (still figuring out all the bells and whistles). It requires users to reload the forum in their browser for it to show up.

Just to double-check, this file exists and when you double-click on it odrive will run, correct?
C:\Users\Michael Angelo\.odrive\bin\4851\odriveapp.exe

Yes, the file exists. When I run it from that folder it runs, but I get a terminal window that I can’t close. It’s not really a problem since the syncing works, but I’m pretty sure it shouldn’t run this way :slightly_smiling:.

Btw, thanks for adding the support for the logs and txt files. I’ve attached them below for reference.

odrive.log (7.3 KB)
odrivelog.txt (723 Bytes)

Thanks. I am going to discuss these outputs with the team tomorrow.

In the meantime, I’ve put together a pretty cool little trick to launch odriveapp without the annoying command window.

C:\Windows\System32\mshta.exe vbscript:Execute("CreateObject(""Wscript.Shell"").Run ""%userprofile%\.odrive\bin\4851\odriveapp.exe"", 0, False:close")

You can copy the above line and paste it directly into the Windows search/run bar, a cmd prompt, or save it to a shortcut. Just remember to change the version number when the software updates.

1 Like

odrive.log (2.2 KB)odrivelog.txt (719 Bytes)

There you go.

Awesome, thanks for the info guys! We’ll dig in and see what we can do. In the meantime Tony’s shortcut about is an OK workaround until we have a proper fix for you. Stay tuned!

No worries, I am still wondering if even after uninstalling and reinstalling that there isn’t a config still out there pointing it to the wrong drive or something.

Weird when I ran that command I got the scripting error of no application is associated with that specified file for this operation. '
Yeah that command line doesn’t start up for me just the error listed above.