Odrive menubar icon not clickable + odrive not working

Hi -
So it happened that today odrive stopped working (OS X Catalina, latest patch). The menubar icon has become unclickable. The app doesn’t show its version number, even though I resintalled it. I’ve cleanly uninstalled and installed again and also tried the (killall -KILL odrive; killall -KILL FinderSyncExtension; sleep 5; cd “$HOME”; rm -r “.odrive/bin”; rm “.odrive/version”; open “/Applications/odrive.app”) fix listed in the recent issues. Nothing seems to be helping.
Odrive is at 0% usage unless I click a .cloudf file, which gets it rolling to 3-6% but without anything happening (I waited to see if it was downloading something, nope). And the Finder Extension keeps crashing.
Any idea?

1 Like

Hi @olivier.piasentin,
Thanks for reporting this issue.

I am running 10.15.4 on my system, but updating to 10.15.5 right now, which was released yesterday. I assume that this is the version you are running?

Was odrive running without issues on 10.15.5 until today?

For the uninstall, did you attempt the “full” uninstall, described here? How do I uninstall odrive?

Hi @olivier.piasentin,
Just an update: I was able to get 10.15.5 installed, but I am not experiencing any issues with odrive (latest version 6683 installed).

Let me know when you get a chance to review my previous post and we’ll go from there.

Hi - thanks for the quick answer. I’m on 10.15.5 indeed and everything was fine until this anomaly.

I uninstalled as per the how-to you linked, then performed 3 times “install, reboot, try, uninstall, reboot”.
Each time I install after a reboot I get it running (starting over, asking me to sign in and creating a new odrive folder in the HDD) but the finder extension won’t work. Double-clicking a .cloudf file would download it though, with odrive at 100% CPU usage. Then if I reboot or properly quit/relaunch, it shows the same problematic behavior: greyed out menubar icon, not clickable. Activity monitor shows it’s running and no Finder extension is loaded.
I have no idea where to go from there.

Thanks for the additional testing and details @olivier.piasentin

I am looking through things to see if I can identify what might be happening here. I will update you as soon as I have more information.

Hello, I am having this same issue on two computers. One running Mojave and one on High Sierra. The app was working fine until a day or so ago, now it is greyed out in the menu bar and I cannot sync any files.

1 Like

Hi @al_canada,
Sorry for the trouble on this. I should have a build to test soon to either address the issue, or help us get to the bottom of it.

@olivier.piasentin and @al_canada I sent you a direct message with a test build and some instructions. Please let me know if you have any questions.

Hi, my Odrive was suddenly stopped working last night. It didn’t sync and there was nothing I can do. The Odrive icon stays in the toolbar but do nothing when I clicked on it.

I browsed the forum and found this script:

killall -KILL odrive; killall -KILL FinderSyncExtension; sleep 5; cd “$HOME”; rm -r “.odrive/bin”; rm “.odrive/version”; open “/Applications/odrive.app”

I did and it worked. Odrive was restarted and asked me to sign in. The moment after signing in, Odrive stopped working again.

I tried to uninstall and reinstall and it’s still not working.

Please help, thank you.


1 Like

Hi @feliz.you,
I sent you a direct message, as well. Can you take a look when you get a chance?

Hi @Tony, thank you for your help. It’s working now.

Thank you.


Great! Thanks for testing that @feliz.you.

Hi same issue here. Running 10.12.6 Sierra on a MacBook Pro early 2011

What is the fix?

1 Like

Hi @sheldon.maye,
Can you give this version a try? https://www.odrive.com/s/e602f11e-849b-4204-b38b-018a971986e4-5ed0a2a0

So, I tried 6689 twice and 6690 twice too.
The Good: in every case odrive is working. The menubar icon works as intended and files sync etc.
The Bad: the finder extension doesn’t work after install. In fact, it only works if I kill the Finder and restart it. Just shutting odrive and restarting it has no effect. Worse, if I restart Finder and everything finally works has intended, quitting odrive then restarting it shuts the finder extension and I have to restart the Finder again.
We’re getting there…

btw, reinstalling odrive respawned two folders tied to gmail accounts that were linked previously. Any chance I can get rid of them?

Thanks for testing @olivier.piasentin! I’ll take a look at the Finder extension issue you are seeing and see what we can do about the lingering Gmail links.

For the Finder extension, if you toggle the odrive extension in System Preferences->Extensions, does it affect the behavior?

A post was split to a new topic: File “syncing” without downloading

I appreciate everyone’s help with this.

Here is a new version that we’re hoping will address the Finder extension loading issues people are seeing. https://www.odrive.com/s/5777166d-c73e-4890-bb99-895836b6ee0a-5ed15c3e

Hey oDrive Team. Looks like I’m part of this new odrive not working club too. I’m running Mac Sierra 10.12.6. Which version of odrive should I try and which process should I try for uninstalling the current version? Thanks

Hi @kimberlykeyton,
I’m sorry you are hitting this too.

Please try the version posted right above your post. You shouldn’t have to uninstall, but let me know how the regular update goes and we’ll see if additional steps are needed.