File "syncing" without downloading

Toggling it on and off restores the right click menu (not the odrive icon in the upper bar of the Finder).

I also realized that some of the files that appear as downloaded are in fact 0k, but their extension is the good one (.mov or .docx for instance) and not .cloudf. Launching/rebooting doesn’t fix it, if I attempt to sync it just does nothing. Unsyncing/resyncing doesn’t yield any other result, the file goes as a .cloud then back to its extension without downloading.

Hi @olivier.piasentin,
The issue you are describing here is very strange. I split it off from the other thread so that we can track it separately.

For the files you are seeing download as 0 bytes:

  • What storage is this?
  • When you go to the storage, directly, or to the odrive web client are you able to download the files with the expected data?

Can you send a diagnostic after performing an unsync and sync on one of these files so I can take a closer look?

After a little more hunting, it only happens on 3 .mov files on my Gdrive account. All other formats seem fine in the end, if I unsync their parent folder then sync it again (I’m doing my best going through file types but we’re talking business not personal so there’s a ton).
I have several .mov sized 100M-1G in several folders which work ok.
Access to Onedrive or my company NAS (SFTP) is working fine too.
Pulling the files from GDrive works. however, odrive web client lists them as “no size”.
Finally, these 3 files are sent from someone else sharing them with me, but this has never caused an issue in the past.

So my take is this specific folder seems corrupted and I just have to pull from GDrive, delete online then resync from odrive to Gdrive.

btw, you are doing a terrific support job , thanks a lot

Thanks @olivier.piasentin! I really appreciate your assistance in digging into this stuff. I was very concerned about this particular issue.

It sounds like Google is reporting them back via the API as having no size. I would like to be able to take a look at raw metadata of one of the files in this state to see what is going on with it, and if we can compensate for it somehow. Since these are work-related and owned by someone else, I’m not sure this would be possible, however.

I am still digging into the Finder extension issue. Catalina introduced odd behavior when compared to previous versions of MacOS. A lot of our recent changes in this area have been done to try to account for this behavior.

One of them, which you already noted, is that the odrive icon in the Finder toolbar will be removed if the Finder extension is disabled and will not be added back when it is enabled again. In previous versions of MacOS it would be re-added, as expected.

Hi @olivier.piasentin,
You may have missed this in the other thread, but there is one more version available.

This will hopefully button-up the issues. It should also be better at retaining the odrive icon at the top of Finder (we made our automatic extension loading a little more intelligent so it will only resort to disabling/enabling if Finder is being particularly stubborn).

We also cleaned up the obsolete links, like Gmail, so you should no longer see those.

Update
This fix has been officially released in our latest version. Thanks for your help @olivier.piasentin! :

I have been using it for one full day now. Everything seems to be fixed. I had a little trouble stopping syncs in onedrive but this may have been due to the fact that some files were huge.
Oh, and the gmails folders are gone too.
Thanks so much for the level of service, this is really the fastest - and most efficient - I’ve seen. This si much appreciated.
Keep up the good work!

1 Like

Great! Thanks for the confirmation and feedback @olivier.piasentin!

As you noted, stopping sync can sometimes take a little while, depending on what is syncing. Stopping an upload it not very useful because odrive will always try to upload changes again, even if you stop it. The only way to stop uploads is to select “Stop automatic sync” in the odrive tray menu.