Odrive 6401 Will not run on Mac OS High Sierra 10.13.5

Recently my odrive desktop sync agent stopped running in Mac OS High Sierra. I uninstalled and reinstalled desktop sync, but still can’t get it to run. I click to open the app but nothing happens.

mine is 10.13.5 and 6401 and all is perfect

1 Like

Hi @yfhudak,

Try these steps and see if it helps:

  1. Open a terminal session (type “terminal” in Spotlight search):

  2. Run the following command in the terminal session (copy & paste + Enter):
    killall -KILL odrive; killall -KILL FinderSyncExtension; sleep 5; cd "$HOME"; rm -r ".odrive/bin"; rm ".odrive/version"; open "/Applications/odrive.app"

This will reset the bin folder and re-run odrive. Hopefully this will clear out the issue. If it doesn’t can you try running this command next?
bindir=$(ls -d "$HOME/.odrive/bin/"*/ | tail -1); echo $bindir;"${bindir}odriveapp.app/Contents/MacOS/odrive"

This will spit out some information to the console, can you copy and paste that here?

Awesome the first command worked for me! Thank You!

Great! Thanks @prestonjohnlewis. I’ll reference this in your other post, too.

Worked for me. Thanks very much!

1 Like