Odrive stopped working

I´ve installed Odrive and synced without problems.
Suddenly last friday the OD icon dissapeared and nothing happened.

I uninstalled, reinstalled, repaired and even made a Restore to a previous point, but now when I install the Odrive again nothing happens, it does not even start.

Hi @mattalt,

Sorry for any trouble caused.

Please follow the steps outlined below:
Be sure to back up any unsync’d files before uninstalling!

  1. Exit odrive and Uninstall odrive using the standard windows uninstall method (add/remove programs).
  2. Goto %userprofile% (or C:\Users\Your_OS_Username\) and enable “show hidden files” in Windows Explorer.
  3. Rename existing “**.**odrive” folder to “.odrive-backup” or move it into Documents folder.
  4. Rename existing “odrive” folder to “odrive-backup” or move into Documents folder (if any).
  5. Install odrive, launch the app and procced with login wizard.

Please let me know if this works for you


Unfortunately nothing happens! Odrive does not start anymore

Can you try running odrive using this command from a command prompt? You can open up a command prompt by clicking on the Windows icon in the taskbar, typing “cmd”, and then clicking on “Command Prompt”.

Once the command prompt is open, copy and paste the following command in (all one line) and hit enter. This will run the odrive launcher and hopefully spit out some useful information. Please wait until the process closes and then copy and paste the output or take a screenshot of the command prompt window and post it here:

powershell -command "&{& \"$env:programfiles\odrive\odrive.exe\" \"-v\" 2>&1 | echo;}"

Now the icon appears but it does nothing, i cannot even setup the odrve

Thanks @mattalt,
Can you stop all odrive processes (check the Task Manager to make sure) and then run this command and let me know the output please?
powershell -command "&{$bin=$(ls \"$HOME\.odrive\bin\" | sort Name -desc | select -f 1).FullName; Start-Process \"$($bin)\odriveapp.exe\";}"

When you ran the command from the previous post, what there any output on the command line?

It´s working again! In fact it started to work after: powershell -command “&{& “$env:programfiles\odrive\odrive.exe” “-v” 2>&1 | echo;}”

Thanks a lot!!

1 Like

Glad to hear it! Thanks for the update.

I’m having this same issue with Mac. I’ve used Odrive for quite some time now on my Mac and I’ve had intermittent issues where even when loading odrive.app it wouldn’t show in the task bar. Usually after refreshing finder it would work again. However, I launch the app now and nothing happens. “odrive Finder Extension” shows as running two instances in Mac Activity Monitor but I’ve restarted my computer multiple times and still the odrive icon isn’t showing in the menu bar on my mac.

The only way I’ve found to get the odrive icon show in the menu bar of my Mac is to double click a .cloudf file. When I do this, odrive icon shows in menu bar for a brief amount of time and then goes away after Finder shows beachball of death for a bit.

I’m running Mac OS HIgh Sierra 10.13.4 and oDrive version prod 6386. I downloaded odrivesync 6401 but when I double click the .app file nothing happens. Feel like I’ve tried everything and there is some weird cleanup needed.

Please help! I am in big trouble without this.

Hi @prestonjohnlewis,
I saw in the other thread that this post worked for you on Mac. I will post here for others, if them come across this thread.