Install error code 0x800713ec asia on many install attempts (Windows)

I’m getting this on several systems when upgrading.

install error code 0x800713ec asia

Same issue here : error code “0x800713ec - Asie” on each attempt to upgrade.

Log says :

[1064:0EEC][2016-08-30T14:20:46]i001: Burn v3.10.3.3007, Windows v6.1 (Build 7600: Service Pack 0), path: C:\Users\W7x\AppData\Local\Temp{9AC32AAC-179C-4940-9E2C-EFC2F746D831}.cr\odrive.exe
[1064:0EEC][2016-08-30T14:20:46]i009: Command Line: ‘-burn.clean.room=C:\Users\W7x.odrive\odrive.exe -burn.filehandle.attached=196 -burn.filehandle.self=204’
[1064:0EEC][2016-08-30T14:20:46]i000: Setting string variable ‘WixBundleOriginalSource’ to value ‘C:\Users\W7x.odrive\odrive.exe’
[1064:0EEC][2016-08-30T14:20:46]i000: Setting string variable ‘WixBundleOriginalSourceFolder’ to value ‘C:\Users\W7x.odrive’
[1064:0EEC][2016-08-30T14:20:46]i000: Setting string variable ‘WixBundleLog’ to value ‘C:\Users\W7x\AppData\Local\Temp\odrive_20160830142046.log’
[1064:0EEC][2016-08-30T14:20:46]i000: Setting string variable ‘WixBundleName’ to value ‘odrive’
[1064:0EEC][2016-08-30T14:20:46]i000: Setting string variable ‘WixBundleManufacturer’ to value ‘Oxygen Cloud, Inc.’
[1064:06A0][2016-08-30T14:20:46]i000: Setting numeric variable ‘WixStdBALanguageId’ to value 1033
[1064:06A0][2016-08-30T14:20:46]i000: Setting version variable ‘WixBundleFileVersion’ to value ‘1.0.5689.0’
[1064:0EEC][2016-08-30T14:20:46]i100: Detect begin, 3 packages
[1064:0EEC][2016-08-30T14:20:46]i000: Setting string variable ‘Net46Installed’ to value ‘378389’
[1064:0EEC][2016-08-30T14:20:46]i102: Detected related bundle: {eeb46a52-e763-4040-aebf-c1eaebf0e493}, type: Upgrade, scope: PerMachine, version: 1.0.5451.0, operation: MajorUpgrade
[1064:0EEC][2016-08-30T14:20:46]i052: Condition ‘Net46Installed >= 393295’ evaluates to false.
[1064:0EEC][2016-08-30T14:20:46]i103: Detected related package: {844E7622-8C32-4207-87E2-D636AB3D94D6}, scope: PerMachine, version: 1.0.5451.0, language: 1033 operation: MajorUpgrade
[1064:0EEC][2016-08-30T14:20:46]i103: Detected related package: {844E7622-8C32-4207-87E2-D636AB3D94D6}, scope: PerMachine, version: 1.0.5451.0, language: 1033 operation: MajorUpgrade
[1064:0EEC][2016-08-30T14:20:46]i101: Detected package: Net46, state: Absent, cached: None
[1064:0EEC][2016-08-30T14:20:46]i101: Detected package: Odrive_x86.exe, state: Absent, cached: None
[1064:0EEC][2016-08-30T14:20:46]i101: Detected package: Odrive_x64.exe, state: Absent, cached: Complete
[1064:0EEC][2016-08-30T14:20:46]i052: Condition ‘VersionNT >= v6.1’ evaluates to true.
[1064:0EEC][2016-08-30T14:20:46]i199: Detect complete, result: 0x0
[1064:06A0][2016-08-30T14:20:49]i000: Setting numeric variable ‘EulaAcceptCheckbox’ to value 1
[1064:0EEC][2016-08-30T14:20:49]i200: Plan begin, 3 packages, action: Install
[1064:0EEC][2016-08-30T14:20:49]i052: Condition ‘(VersionNT >= v6.0 OR VersionNT64 >= v6.0) AND (NOT Net46Installed >= 393294)’ evaluates to true.
[1064:0EEC][2016-08-30T14:20:49]w321: Skipping dependency registration on package with no dependency providers: Net46
[1064:0EEC][2016-08-30T14:20:49]i000: Setting string variable ‘WixBundleLog_Net46’ to value ‘C:\Users\W7x\AppData\Local\Temp\odrive_20160830142046_000_Net46.log’
[1064:0EEC][2016-08-30T14:20:49]i052: Condition ‘NOT VersionNT64’ evaluates to false.
[1064:0EEC][2016-08-30T14:20:49]i052: Condition ‘VersionNT64’ evaluates to true.
[1064:0EEC][2016-08-30T14:20:49]i000: Setting string variable ‘WixBundleRollbackLog_Odrive_x64.exe’ to value ‘C:\Users\W7x\AppData\Local\Temp\odrive_20160830142046_001_Odrive_x64.exe_rollback.log’
[1064:0EEC][2016-08-30T14:20:49]i000: Setting string variable ‘WixBundleLog_Odrive_x64.exe’ to value ‘C:\Users\W7x\AppData\Local\Temp\odrive_20160830142046_001_Odrive_x64.exe.log’
[1064:0EEC][2016-08-30T14:20:49]i201: Planned package: Net46, state: Absent, default requested: Present, ba requested: Present, execute: Install, rollback: None, cache: Yes, uncache: Yes, dependency: None
[1064:0EEC][2016-08-30T14:20:49]i201: Planned package: Odrive_x86.exe, state: Absent, default requested: Absent, ba requested: Absent, execute: None, rollback: None, cache: No, uncache: No, dependency: None
[1064:0EEC][2016-08-30T14:20:49]i201: Planned package: Odrive_x64.exe, state: Absent, default requested: Present, ba requested: Present, execute: Install, rollback: Uninstall, cache: No, uncache: No, dependency: Register
[1064:0EEC][2016-08-30T14:20:49]i207: Planned related bundle: {eeb46a52-e763-4040-aebf-c1eaebf0e493}, type: Upgrade, default requested: Absent, ba requested: Absent, execute: Uninstall, rollback: Install, dependency: None
[1064:0EEC][2016-08-30T14:20:49]i299: Plan complete, result: 0x0
[1064:0EEC][2016-08-30T14:20:49]i300: Apply begin
[1064:0EEC][2016-08-30T14:20:49]i010: Launching elevated engine process.
[1064:0EEC][2016-08-30T14:20:49]i011: Launched elevated engine process.
[1064:0EEC][2016-08-30T14:20:50]i012: Connected to elevated engine.
[0F64:1024][2016-08-30T14:20:50]i358: Pausing automatic updates.
[0F64:1024][2016-08-30T14:20:56]w308: Automatic updates could not be paused due to error: 0x80070422. Continuing…
[0F64:1024][2016-08-30T14:20:56]i360: Creating a system restore point.
[0F64:1024][2016-08-30T14:21:01]i361: Created a system restore point.
[0F64:1024][2016-08-30T14:21:01]i370: Session begin, registration key: SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall{203f67eb-d433-474d-87a3-699c217d0be2}, options: 0x7, disable resume: No
[0F64:1024][2016-08-30T14:21:01]i000: Caching bundle from: ‘C:\Users\W7x\AppData\Local\Temp{211C6FE8-9A10-4540-B7C3-D15E9473AC08}.be\odrive.exe’ to: ‘C:\ProgramData\Package Cache{203f67eb-d433-474d-87a3-699c217d0be2}\odrive.exe’
[0F64:1024][2016-08-30T14:21:01]i320: Registering bundle dependency provider: {203f67eb-d433-474d-87a3-699c217d0be2}, version: 1.0.5689.0
[0F64:1024][2016-08-30T14:21:01]i371: Updating session, registration key: SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall{203f67eb-d433-474d-87a3-699c217d0be2}, resume: Active, restart initiated: No, disable resume: No
[0F64:06B8][2016-08-30T14:21:01]i305: Verified acquired payload: Net46 at path: C:\ProgramData\Package Cache.unverified\Net46, moving to: C:\ProgramData\Package Cache\480CA134B9E3F2437DF10719D5A8C77DDEC0A4F1\Microsoft .NET Framework 4.6 Setup.
[0F64:06B8][2016-08-30T14:21:01]i304: Verified existing payload: Odrive_x64.exe at path: C:\ProgramData\Package Cache{5F9AF45D-B731-413E-93F0-5A7DC153C7A0}v1.00.5689\odrive.x64.msi.
[0F64:06B8][2016-08-30T14:21:01]i304: Verified existing payload: cabF86E6C821B5C13030D55C93C8C703EA3 at path: C:\ProgramData\Package Cache{5F9AF45D-B731-413E-93F0-5A7DC153C7A0}v1.00.5689\odrive.cab.
[0F64:1024][2016-08-30T14:21:01]i301: Applying execute package: Net46, action: Install, path: C:\ProgramData\Package Cache\480CA134B9E3F2437DF10719D5A8C77DDEC0A4F1\Microsoft .NET Framework 4.6 Setup, arguments: ‘“C:\ProgramData\Package Cache\480CA134B9E3F2437DF10719D5A8C77DDEC0A4F1\Microsoft .NET Framework 4.6 Setup” /passive /norestart’
[0F64:1024][2016-08-30T14:21:08]e000: Error 0x800713ec: Process returned error: 0x13ec
[0F64:1024][2016-08-30T14:21:08]e000: Error 0x800713ec: Failed to execute EXE package.
[1064:0EEC][2016-08-30T14:21:08]e000: Error 0x800713ec: Failed to configure per-machine EXE package.
[1064:0EEC][2016-08-30T14:21:08]i319: Applied execute package: Net46, result: 0x800713ec, restart: None
[1064:0EEC][2016-08-30T14:21:08]e000: Error 0x800713ec: Failed to execute EXE package.
[0F64:1024][2016-08-30T14:21:08]i351: Removing cached package: Net46, from path: C:\ProgramData\Package Cache\480CA134B9E3F2437DF10719D5A8C77DDEC0A4F1
[0F64:1024][2016-08-30T14:21:08]i372: Session end, registration key: SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall{203f67eb-d433-474d-87a3-699c217d0be2}, resume: None, restart: None, disable resume: No
[0F64:1024][2016-08-30T14:21:08]i330: Removed bundle dependency provider: {203f67eb-d433-474d-87a3-699c217d0be2}
[0F64:1024][2016-08-30T14:21:08]i352: Removing cached bundle: {203f67eb-d433-474d-87a3-699c217d0be2}, from path: C:\ProgramData\Package Cache{203f67eb-d433-474d-87a3-699c217d0be2}
[0F64:1024][2016-08-30T14:21:08]i371: Updating session, registration key: SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall{203f67eb-d433-474d-87a3-699c217d0be2}, resume: None, restart initiated: No, disable resume: No
[1064:0EEC][2016-08-30T14:21:08]i399: Apply complete, result: 0x800713ec, restart: None, ba requested restart: No

its an old old microsoft .net error, as old as xp, no one seems to have any real fix for it. some suggest installing everything .net as old as 2008, development packs and all. but ive not read if that did anything to fix it.
everything else is a shill for fixit programs, and have no solutions either.

something I have seen with people dealing with this error and other programs is its some sort of protection error, a piece of .net is being used by something else has is preventing it from installing completely. if thats the case i dont know how to force a protected install.
if the installer can be forced to continue beyond the error, maybe it will be ok.

some people have defeated the problem by flushing the install program cache, others say that made no difference.

maybe try an admin mode install from a new download? and not the upgrade? I hadnt tried that yet. just install a new one over the old one at the highest priveleges.

This is a terrible error by Microsoft, but it is due to not having an updated Windows system. This is commonly seen on Windows 7 if SP1 is not installed (7601 vs 7600). Some users have also encountered this with Windows 8.

Our ongoing effort to improve the Windows UX includes a dependency on .NET 4.6 now. Installing .NET4.6 separately may work, or at least give a more meaningful error message: https://www.microsoft.com/en-us/download/details.aspx?id=49981

Information on installing Service Pack 1 for Windows 7, which is required for .NET 4.6: https://support.microsoft.com/en-us/help/15090/windows-7-install-service-pack-1-sp1

Information on upgrading Windows 8 to Windows 8.1: https://support.microsoft.com/en-us/help/15288/windows-8-update-to-windows-8-1

for reasons i never understood, i have windows 7 systems that were never able to install SP1. the previous version works fine on those.

What happens when you try to install SP1 on your machines? Definitely odd that you would have this issue on multiple machines.

I’m getting the error on a Windows 8 (original) laptop. Uninstalling and installing fresh didn’t help. Able to run version 5453, but not 5720.

Is there any way we could reduce the frequency of the update prompts? (because I can’t)

Thanks!
-Martin

Hi Martin,
There should be some install log located in a temp directory after running the install. If you run the install (which will fail), then copy and paste %userprofile%\appdata\local\temp into the Windows Explorer address bar, hit enter, then sort the files by date modified, you should see some log files listed at the top. I will want to look at those. Particularly, there should be one for the .net install attempt.

After that, can you try installing .net 4.6 separately and see if it generates an error?
https://www.microsoft.com/en-us/download/details.aspx?id=49981

Thanks!

going to agree there. its obvious i have several stations that will never upgrade, i need to disable it.
there is one way, its called ‘basta busoff’ it waits for windows and selects what ever button is the appropriate one, another is auto hotkey.

You can dismiss the notification for a day with the “remind me tomorrow” option. That is the extent to which you can delay it. I suppose you can also minimize the window, but leave it around. I believe that would also prevent it from popping to the foreground again, although it leaves the item in the taskbar.

Tony,

a separate .net install also failed.

the error message on that install sent me to here:
https://support.microsoft.com/en-us/kb/2919355
so it looks like I need to update windows 8 first.

I’ll do that in the next few days and report back.

Thanks!
-Martin

I appreciate the update @steff2j

.net 4.6 is “supposed” to work on Windows 8, but it sounds like this is not the case for you. Did you happen to capture the error window when installing .net on its own?

After the Windows 8 update, the odrive installer 5720 worked without a hitch. Thanks for the suggestions on trying the .net install separately, which gave the error message about updating windows.

Cheers!
-Martin

Great!
We’ve modified the installer to show a .net error, if one occurs. Thanks for the update.

I could not update Windows 7 to SP1. Is there any way to download an old version compatible with Windows 7 without SP1?. I don’t mind if UI is worse or has some functionalities missed out. If not, I won’t be able to use your application for now.

Thank you

Regards

This…is a problem. I’m currently running Win8, and I expect that if I attempt to install .net independently I will get an error whose solution is to update Windows. Now, every time I update Windows (which I haven’t done on this computer, ever), it breaks something - a program I use regularly, a feature I rely on, something that can’t be fixed and must be worked around and re-learned. So I refuse to update Windows to see if that solves this problem, because it will create even more problems than it (potentially) solves. Is there anything else I might be able to try in order to bypass this error and install odrive? I’ve been using installer 5926, if it makes a difference.

Hi @javier and @Alyksandrei,
Unfortunately there isn’t a way to work around this. We updated odrive to use a more recent version of .net, which requires the newer .net framework to be installed. It is supposed to be an easy install of the framework on Windows 7 SP1 and up, but it looks like vanilla Windows 8 needs an update too…

Apologies for the inconvenience.

i realise this is a year oldl, but ive just downloaded odrive to try anf replace onedrive which is using to many resources. unfortunately it wontinstall same dot net error i think looking at the log files tries to run wsusa.exe but fails. using win8 im not going to upgrade it or update as that WILL break other stuff i use. any ideas on this. i just need to sync onedrive .