High CPU usage on OS X

i run Mac v4952 and i have an odriveapp process that is constantly at 100% CPU (Activity Monitor). I think this also happened before the update but it is persistent now.

Thinks i already tried:

  • completely removed odrive (as per your instructions) and reinstalled
  • created a new blank account (one with google, one with amazon)
  • even created a new account with no links in it

result: as soon as the desktop-client is linked with an account the cpu usage jumps to 100% and never goes down.

maybe a bug with the osx-client and/or your server?

EDIT: as it seems the CPU usage goes to normal after ~15 mins. But restarting odrive starts the CPU usage again (again: even with zero services linked).

EDIT2: the timespan seems to be more like ~20min. Additionally: Shortly before the CPU usage drops, it goes up a little, the odrive-status-icon indicates activity (which is not the case otherwise, also: no specific actions are indicated in the odrive-menu).

So you are seeing high odrive CPU usage for over 15 minutes with no links at all? That is strange, indeed. Can you reproduce that scenario and send over a diagnostic to look at?


i did send a diagnostic just now (odrive was in 100% CPU mode)

i can and did reproduce it. even with a new account with no links on a cleanly removed and reinstalled odrive (right now i have a few links active though).

Sorry for the delay in getting back to this one.

I took a look and it appears that odrive was in the process of scanning through a fairly large folder structure (~250 folders). That can cause some heat. odrive will do a scan periodically, but it does kick one off when odrive is started, which is why you may see activity right when odrive starts. Other than that I do not see anything abnormal.

Are you still seeing unexplained high CPU?

behaviour is still the same. ~20min of 100% CPU. can you tell me what folders exactly odrive was scanning? especially if there is no synced folder in my odrive, why the scanning?
and this kind of cpu usage would be enough to index almost a whole hard drive, not just scanning 250 folders.
i’m a software developer myself and this clearly feels like a bug in the odrive startup procedure.

To clarify, are you only seeing this on startup, or is it happening regularly? The extreme to which you are seeing activity is unusual and not something I am able to replicate. I have many, many expanded links and CPU will jump on startup on my OSX systems, but it will calm down relatively quickly (within about 2 minutes).

Are you seeing anything displayed in the odrive tray menu during this time?
Does it make any difference if you close all Finder windows?


this is exclusively (and always) happening on startup of odrive. meaning: system startup, log-out log-in, quitting odrive and restarting it (wake from sleep is fine).

no display in the menu, except a short syncing animation at the very end of the 20min full-throttle run.

no difference about the finder windows.

to say it again: i also re-installed everything (including deleting all library-files) and created a new odrive-account.

I also am having the same experience with OSX with an external HD hooked up. On startup the CPU jumps up to about 120% (Max was 160%) for about 10 minutes. Then after 10 minutes it calms down and uses around 10% CPU. I have my main odrive folder as well as an external hard drive syncing folders.

Can you tell me how large the external hard drive is in # of files and folders? What service is it associated with. Also, what are the specs on the Mac?

If you are syncing very large structures then it is not uncommon to see spikes on startup, as odrive will go through the whole structure to verify the contents and check for changes.

Yes no problem, the Hard drive is 2Tb using 1.5TB of it. There are indeed a lot of files associated and may very well be the cause. When the external drive isn’t plugged in. I am not noticing the fan and large CPU using on startup. Their is a 10-15 minute window now of high usage then it appears to stall with it toggling between Pause Sync and Stop Sync

The Process Name in question is odriveapp.
The service we are using is Amazon Cloud Storage.
The Mac Specs are:
2.3 GHz Intel Core i7
16 GB 1600 MHz DDR3
NVIDIA GeForce GT 750M 2048 MB
and the External Hardrive is a WD MyPassport for Mac 2TB HD

Also I just sent diagnostics

Thanks. I took a look and it is as we suspected. Correct me if I’m wrong, but I think you have your Apple Photos library on that drive, right? (I saw some rate limit exceptions from ACD for a Photo library structure).

That dang Photos library structure is absolute hell for syncing because of the ultra-nested directory structures. The more folders, the more calls we need to make when odrive starts up to see what is in those folders, and the Photos Library is terrible in that regard.

That all being said, its not really a problem, but it will cause a bunch of heat when odrive starts up, and periodically after that when it needs to go through the entire structure.

Nailed it, yes Apple Photos is on that drive. I will probably just move this to another drive that I don’t use as much because I really don’t use Apple Photo anymore. Thanks for your help!

1 Like

Just leaving a note here for future readers.

If you need to get apple photo into the cloud … instead of sync … use right-click backup (new feature coming in the next couple weeks). Backup is a simpler process and a better feature to use when you don’t need to sync bi-directional changes.


I have noticed similar behavior on OS X odrive startup, yet my cloud drive (Amazon) is empty; I actually do not have anything stored in it at this point because I noticed the issue when I installed it. There are folders in the Amazon Cloud Drive folder, which seem to be standard ones for that service – they are also empty. I agree with the first poster that it runs at 100% CPU for about 15 minutes and then drops.



Hi Jim,
You are saying that you have nothing exposed in odrive and it still has this issue?

Can you send over a diagnostic from the odrive tray menu?


Hi Tony,

Yes, I have nothing exposed in odrive and it still runs high on startup. I sent a diagnostic per your request (it just sort of sent, so I hope you can see it). I have attached a screen shot of activity monitor from my startup this morning. The capture is about 3 minutes after startup. It is now about 10 after and it is still hovering at 100%. I expect it will drop to normal in 5 minutes or so.



Thanks. Looking at the diagnostics, it appears odriveapp was occupied with filtering out a massive amount of superfluous filesystem events from Evernote.

OS X notifies odrive of filesystem events so we can understand where odrive-related activity is happening (like someone trying to drag a placeholder file from odrive to somewhere else). We are discussing ways to constrain/limit this to prevent very noisy apps from flooding OS X filesystem events.

You may not still be seeing this, but if you are, can you try closing Evernote and seeing if there is any difference?


Hi Tony… wow, Evernote. I’ll check to see what it is doing when I start-up my computer and shut that down. I’ll let you know …

Appreciate the follow-up. Will be curious to hear if you see any difference.

Hi Tony,

I noticed odrive was using a lot of CPU again on boot. I shut down Evernote in the tray and made sure it was not running elsewhere. It did not seem to have an impact.