Cannot Sync on Mac

Hi, I’m having issues syncing files on a Mac running OSX Sierra public Beta.

Each time I try, the pink ‘sync’ icon appears momentarily, then disappears a few seconds later. I am syncing from box.com, running Prod5719, I’ve sent a diagnostic.

Fixes I’ve tried:

  • Restarting Odrive
  • Rebooting my machine

It’s important to note that, although I am running a Beta OS, the problem only began today, and I’ve had Odrive running fine with the Beta installed for some time.

UPDATE:

I checked my other linked accounts (dropbox, google drive), and they were syncing just fine. I went and checked my linked accounts from the web portal and noticed that none of my folders were appearing in the Box.com section. When I clicked the little refresh icon, it prompted me to re-authorise Box (it had done this last week as well, but I think that Box had some server maintenance going on at the time, so it may have gotten a little confused), which I did…and presto! Syncing like a charm! :slight_smile:

Certainly still a bug worth exploring as ODrive didn’t automatically identify the need to re-authorise as it normally does.

Thanks @creaturesfarley, we are glad to know, things are sorted out =)

We’ll shortly conduct more tests and see where app doesn’t prompt user to re-authorize the storage.

Generally, odrive prompt re-authorize message on each foreground actions (e.g. initiated by user, such as expanding a file or folder) and just once on background jobs (e.g. initialed by app, such as uploading a file to storage), once dialog window is dismissed it won’t re-appear for background jobs.

Thanks,
Asif

Hiya Asif

Thanks for your reply - the same issue has just happened again. I got no prompt within the desktop application, and only prompted me when I went into the ODrive web portal, and clicked the ‘refresh’ button when I tried to view my box.com files.

I’m currently using the Mac OSX Sierra beta, so that may be causing some kind of issue.

Sierra Beta is not fully supported by odrive. A new release is coming next week that will properly support Sierra. Sorry for the confusion.

Hi Peter

I understand that Sierra is not supported, which will explain why I’m not being prompted to re-authorise, but the fact that I am being asked to re-authorise now on a daily basis should be unrelated to my OS. This is surely an issue on the server side.

I’ve looked through the support forums and found evidence that this has happened to other people, too.

Thanks

Yes, you are correct. Reauthorize is not related to Sierra.

odrive needs to reauthorize when the source authorization token expires. Generally, these tokens do not expire on a daily basis since that would be super annoying. Something may have changed.

To confirm, this is only happening with Box? And you need to reauthorize daily?

I’ve only noticed this happening with Box currently, but Box is also the only account that I use regularly, so I don’t know if this might change if I start syncing to the other services. I’ll aim to test this today.

I’m asked to reauthorise every day. I generally go to bed at around 11pm BST (UK time), and when I wake up the following morning, I’ll need to reauthorise, so it must be happening sometime during the night. I’ll aim to try and tie down exactly what time it happens if I can.

I’ve contacted Box support, too. Just to see if this is something that they’re getting a lot of on their end. I don’t have any other services linked to my Box account, so I’m not sure if it’s a more widespread problem within Box. A ticket has been created, and I’m just waiting for someone from Box to come back to me.

Hope this is all helpful. Thank you for your quick replies. :slight_smile:

Did some research and Box tokens should last 60 days, but there are some restrictions. We will review the box integration. Thanks for reporting the issue!

We are looking into the Box issues, but I wanted to let you know that we have a Sierra release available for download: