Unexpected error Please try again later when attempting to sync folder

I have synced TBs of data to my Amazon Cloud Drive account with Odrive on OSX. I am down to the last 500GB located in two folders and the folders are not syncing. When I manually right click and hit sync I am presented with error message “Unexpected error. Please try again later.” I have been attempting to upload these folders all day. I’ve done restarts of the machine, uninstalled and reinstalled Odrive, etc. but they still won’t sync. The error message is not very detailed. Where are some logs located so that I can try to get to the root of this issue?

Can you send a diagnostic from the odrive tray menu so I can take a look and see it that reveals anything?


Hi Tony, I just sent the diagnostics. Thanks!

Hi Ryan,
I am taking a look now. Can you tell me what path it is that you are getting this exception on? You can PM me directly if you do not want to put it here.




Hi @ryanmckeague,
There are a couple of specific paths that are causing some issues in these two paths, resulting in them bombing out. We are discussing how to better handle it, but in the meantime I will PM you the paths and you can try to address them manually.

Im running into this error right now. Files and folders in our mapped o drive are not syncing up to the cloud. If I go to the web portal and create a new folder there, it syncs down to the o drive. I edited the name of the folder that synced down but the change did not sync up to the cloud.

When I force a sync, I get the unexpected error occurred message.

I have this issue on two different machines, one of them is a fresh install.


Is there anything of note about the name? If you rename the folder to a single character (like “a”), does it still exhibit the behavior?

Can you send a diagnostic from the odrive tray menu along with the problem paths?

Im testing with a folder with a very short name and also a file with a very short name. The user Im supporting had a file path length of 100 characters.

I think what may be happening is that you are acting on folders within the root of the Oxygen Cloud folder, which cannot be done from the client. Oxygen Cloud is unique in that is has a concept of Spaces that are shown in the root of the “odrive\Oxygen Cloud” folder. These spaces can only be created, renamed, and deleted from the Oxygen Cloud web client. All user-created content needs to be worked on within a Space.

In short, nothing can be done directly inside the Oxygen Cloud folder. You have to be at least one level deeper, in a Space.

Does that make sense?


I’ve the same problem reported at this post: “Unexpected Error”

My problem is with DropBox and the local path are folders inside “D:\odrive\Dropbox\Documentos\UOC\Asignaturas” as: “Legislacion_y_Regulacion”, “Sistema de Gestión de la Seguridad” or “Vulnerabilidades de Seguridad”. I’ve tried to rename the folder in order to put a simpler name like “a” but the problem persists.

I’m working with the last Windows version (5914).

Are there any solution for this issue?

Some screenshoots:

Best Regards,

Can you send a diagnostic from the odrive tray menu please?



Diagnostics has been sent in this moment.


I don’t know why, but in the last reboot, odrive didn’t starts with Windows. I thought this problem was resolt in the last release.

Best Regards,

Are you still having issues starting odrive?

As for your issue it looks like a strange exception that I need to investigate further, but I believe renaming the files as follows should correct the problem:

Rename the folders to exactly:
D:/odrive/Dropbox/Documentos/UOC/Asignaturas/Legislación y regulación
D:/odrive/Dropbox/Documentos/UOC/Asignaturas/Sistema de gestión de la seguridad
D:/odrive/Dropbox/Documentos/UOC/Asignaturas/Vulnerabilidades de seguridad

The exact capitalization is important. If it does not work, please send me another diagnostic.


Hi Tony,

I’ve renamed the folders as you write, and it seems to start working: folders in “Asignaturas” was syncronized (https://goo.gl/YiJwDr)… But I’ve had to stop and restart odrive in order to force the content of this folders to be syncronized.

Despite this there are some folders are not still syncronized (http://bit.ly/2d2zoz3),for example “No evaluables”. Its original name was “NO evaluables” but seeing that more than one capital leter could cause errors I’ve decided to change its name.

I’ve sent you a new diagnostics logs.

Best regards,

Hi @edgar.munoz77,
The issue isn’t with the number of capitals, but with the renames. There are some renames that are being picked up as deletes, although I’m not sure why. In any case, since the deletes are not committed to the cloud (in the odrive trash), the new name, which is just a change in the capitalization, is not allowed to sync.

These simple renames should not have issues, so that is something that we need to look at. For this latest folder, you need to rename it to, which is the same name of the folder in the odrive trash (you can take a look there to verify):
“No Evaluables”

Hi @Tony,

I confirm you that, after renaming the folder to “No Evaluables”, syncronization works fine.

I don’t understand what you say about de “deletes are not committed to the cloud”. I try to empty trash every few time. The most normally is that my odrive trash is empty.


In this case the renames you were performing were somehow picked up as deletes. Since they were held in the odrive trash, the items still existed in the cloud. The renames ended up being capitalization changes, so Dropbox was rejecting the new folder name because it already exists in the cloud, just with slightly different capitalization.

OK. Thanks @Tony