Syncing odrive with Amazon on a Mac - odd sync discrepancies causing problems


I’m having some trouble - everything seemed to be working fine during my first push to Amazon, I simply set each folder in my user folder (and all subfolders) to sync and the data found its way to Amazon. As far as I know, it’s still doing this as new files are appearing there within the various folders. I’ve since rebooted my machine and each time this occurs odrive seems to go through a somewhat lengthy sync (lengthy considering nothing has changed). That’s fine and all, except now it doesn’t indicate when certain folders are/aren’t synced.

Here’s a link to an imgur album that shows my user folder with the synced materials - every single folder had a blue checkmark next to it prior to my first reboot, and now, even after repeatedly setting Creative Cloud Files, Desktop, Documents, Downloads, Movies, Music, and Pictures to sync (again, including all subfolders, setting the maximum file size, etc), there’s no side icon indicating sync status, right-click gives me the same options as before (sync, refresh, remove sync, open web preview), and even after letting the computer sit and run (until the odrive icon at the top of my screen goes black, indicating that everything has synced), I still don’t see that these folders are syncing. Does my odrive folder look correct? Any ideas? I have a premium account.

Hi Ryan,
Can you try adding a new file into one of the folders that is not showing the expected badging and verify that it is sent up to the cloud (check remote view with odrive web client or the Amazon Drive web client)?

When you drill into those folders, do you see any badges, or are they missing from the whole structure?

Can you also send a diagnostic from the odrive tray menu so I can see if anything sticks out?

With such an extensive structure to monitor, I would expect some heavy processing initially when you reboot your system. The reason is because odrive needs to make a scan pass to make sure nothing has changed.

I notice you have your Applications folder being synced, which is a little surprising since Applications typically doesn’t contain any user data, so syncing it is generally no useful and can be very heavy because of the extreme nested structure for some applications.

I also see you are syncing Dropbox and Google Drive, which are, themselves, being acted upon by other sync engines. This is generally not recommended because it hasn’t been tested on our side and the concurrently running sync engines can potentially conflict with each other. You may be having success with it, though.


I’ve successfully synced many new files to Amazon in various folders and verified their presence via the Amazon web interface (desktop, documents, downloads, pictures, and movies) - all of which are missing badges regardless of structure [e.g. downloads doesn’t have any other folders, currently, Desktop only has 2 folders and a few dozen files]). Just to emphasize: after the first, very long run, badges were present on every single folder.

Regarding Dropbox and Google Drive: understood, haven’t had any trouble yet. As for Applications - this is not the main Applications folder, it contains data from two applications totaling less than 1mb of data.

Finally, I sent the diagnostics just now. Thank you!

1 Like

Have you tried toggling the finder extension ON/OFF? You can find this in system preferences.

1 Like

It worked! Thank you.

1 Like

Hate to bring this up again, but despite toggling the finder extension ON/OFF and even rebooting and restarting odrive, I’m still running into this same issue - but this time it doesn’t show me ANY badges for extended periods of time and when it does show them, the same thing is happening as last time, with primary folders such as DESKTOP, DOCUMENTS, DOWNLOADS, MOVIES, MUSIC and PICTURES not having badges of any kind next to them, even if I right-click and sync (and set it to DOWNLOAD EVERYTHING and select it to INCLUDE SUBFOLDERS and SAVE AND APPLY TO NEW FILES AND FOLDERS).

I’ve submitted the diagnostics in advance as of this writing, FYI.

Hi @ryan1,
I couldn’t find a diagnostic. Can you try sending another one over when you see this? Please let me know what time it was sent, as well.

When this does occur, do you still see right-click options on the folders, even though you dont see the badges?
In extensions, is there anything else listed besides the odrive extensions?


A post was merged into an existing topic: “dot” files (such as .DS_Store, .localized, etc) don’t sync properly to Amazon Cloud Drive