SFTP Connection Issue

So my network configuration is as follows:

  1. NetGear Router (with public IP A)
  2. Synology NAS (with local IP B)

A:2722 forwards to B:22

The NAS is configured to support SSH with key.

I could sftp -P 2722 admin@A in any of my computer terminals and also from a remote server, and I can see logs in both my router and NAS. Now I have a link in odrive created for this SFTP setup, and it always says “Cannot browse SFTP. SFTP server error.”. And I can only see the connection log in my router but not in the NAS.

Any help would be much appreciated.

Hi @zodiase,
Have you tried using the desktop client to browse. If so, does that work?

It may be similar to this thread here: Cannot browse NAS. SFTP server error

There is a fix that is waiting for deployment which will address the issue on the web client. The desktop client should work despite this, however.

Unfortunately the desktop clients, I’ve tried both on Windows and OSX, report the same error.

Hi @zodiase,
Can you send a diagnostic from the odrive menu so I can take a look?

I clicked on the “Send Report” and nothing else happened. Is that what you need?

Hi @zodiase,
It looks like it may be related to cipher support. Do you know what you ssh config is on the Synology?

That’s a great pointer. So I went to the security settings for SSH and turned the level all the way to “low” and it finally worked! Thanks for the help!

Thanks for the update @zodiase. Glad to hear you have it working.

We are going to be issuing a small update to SFTP soon which will add some additional cipher support. I don’t know if it will address your issue, but it might, so keep an eye on our release notes section: https://forum.odrive.com/c/release-notes

I’d like to give an update. I previously reported it working but it was only on the odrive website. Later when I try to sync the SFTP folder on my macbook, it still prompted “SFTP server error”. Then I tried creating a new SFTP link and somehow that worked, even with identical configurations.

However, that’s just on my macbook. Now I can’t get it to work on my Windows laptop. Whatever I try it always says “SFTP server error”. The odrive client is at “prod 6230”.

I just clicked “Send diagnostics” as I’m typing this.

Hi @zodiase,
The error coming back is that the server is refusing the connection. Doesn’t give us much to go off, unfortunately. Is this machine in the same location as your Mac?

Do you have a test account I can try to use to see if I can debug further?

OK I’m sorry I don’t want this to sound ridiculous but after some fiddling it’s now working for both my Mac and Windows computers… I’ve changed many things back and forth so I’m not exactly sure, but I was testing with sftp and noticed some refused connections when using the public domain (even though it works on the odrive website). Then I set an explicit port forwarding for port 20-22 on my router, even though those ports were already being forwarded by UPnp rules, and now it’s working, somehow.

Hi @zodiase,
Thanks for the update! Glad you’ve got it working now.

It certainly doesn’t sounds rediculous. These things can be temperamental and finicky. :slight_smile: