Set auto empty trash; After one day

I am deleting files on my HDD but after one day the files are still in the Trash bin.
And therefore still in the cloud. Manual ‘Empty trash and sync all deletes’ works fine.
Why is this not working according to the setting? Prod 6989 on Windows (11)

Hi @jeroen.halbesma,
This should be working, but I am testing it now.

The interval will be a full 24 hours from the time odrive picked-up the delete. Keep in mind that the interval will be reset if odrive is restarted, since it does not persist the trash items across odrive sessions (it detects the items, anew, when it starts up).

Oke, thanks Tony. Your answer “Keep in mind that …” explains it.
My system seldom on for 24 hours. I will switch back to 1 hour.

1 Like

Hey @jeroen.halbesma,
Our latest version added a custom interval ability as an advanced configuration option. You could try that out to set a more appropriate interval:

Took me a while to find it, “autoEmptyTrashIntervalMins”: 3600,
Thanks :+1:

1 Like

Hey @jeroen.halbesma,
Here is the documentation: Advanced client options

The setting is in minutes, so 3600 would equal 60 hours, for example.

Oops, set it to a more appropriate value for me, 300 minutes for a working day. Thanks again.

1 Like