Odrive not syncs only GDrives

Just installed Odrive (bought premium). Added 2 GDrive accounts and 1 OneDrive. OneDrive is syncing without problems.

The 2 GDrives are not syncing. I can browse them on the web interface, but if I try a double click on the .cloudf placholder it keeps asking me to re authorize.

I’ve tried waiting 5 minutes, unlinking and relinking, nothing change.

Please help.

Hi @flodi,
Can you reproduce this with both links, again, and then send a diagnostic from the odrive menu so I can take a closer look? This behavior is not expected.

I clicked both, I was asked to authorization, I gave it. Waited 5 minutes, clicked again: again auth request.

Clicked Send Diagnostic.

Hi @flodi
Unfortunately I haven’t seen your diagnostic come in. Can you try sending it again?
Can you also tell me what the user name is on that computer? That info can help me track it down if it came in.

Do you have any firewalls, proxies, antivirus, or any other types of network intermediary or background process that could be involved in your computer’s attempts to communicate to Google?

Can you also try this test?
Create an odrive Space against each of your Google links (https://docs.odrive.com/docs/share-with-odrive#section-share-storage-with-spaces). You can use your own e-mail for the invitation since you are just creating this for yourself, and not to share with others. Once you have created the Spaces they will be available in the Spaces folder inside the odrive folder on your desktop. See if you are able to browse/upload/download in those Spaces.

I’ve done it again.

No firewall, proxy or whatever. And btw using ExpanDrive I can mount google drivers without problems.

Done the test. In spaces I see the link and can browse my google drives

Hi @flodi,
Thanks for getting back to me! I know this is a pain, so I appreciate your help.

Unfortunately I am still not seeing a diagnostic for you.

The issue you are seeing here is one I don’t think I’ve seen before. It may be that an error is being returned that is being incorrectly interpreted as a reauthorization scenario. What is interesting is that you are able to use Spaces and the web client just fine, which uses the same authorization flow and tokens.

You can definitely continue using Spaces as an interim workaround until we can figure out what is going on here.

It may be beneficial to try a full uninstall and reinstall to see if the issue persists, also, if you are willing to do so. ( How do I uninstall odrive? ). If you are able to do this, please try sending a couple of diagnostics after the reinstall:

  • First, send one right when odrive starts-up, before trying to expand any folders.
  • Next send one right after trying to expand one Google Drive folder, if the problem is persisting.
  • If you saw the same error, then immediately try opening that same Google Drive from your Spaces and confirm everything works as expected. Send one more diagnostic.

As for the username, I am looking for the username on the computer, itself, rather than the odrive username (they might be the same, but I just wanted to make sure).

Uninstalled, reinstalled. Sent 2 diagnostic, one before and one after logging in.

Send another one after double click on a Google drive folder as given authorization

Sent another one after nanvigating - successfully - through spaces links.

The computer name is thinpower

Hi @flodi,
Thanks for going through those steps. Nothing is coming in from you, unfortunately, which is odd, in itself.

Can you see if you have a file called “current_odrive_status.txt” in the root of your odrive folder? That file should be generated whenever a diagnostic is sent and provides some information on the current state of odrive. If that is available, can you attach it here?

Can you also provide some information on your system? (Operating system and version, any anti-virus/malware software installed, other sync software installed).

Do you have any other systems you can test on to see if the issue persists across multiple computers?

I have also asked our operations team to see if they can take a look at the calls your client is making to the odrive servers. We can’t see any direct calls to your storage, but maybe we can see something in the calls we can see.

Yes, I see the file created current_odrive_status.txt (83.6 KB)

I’m on a macbook pro 15 with latest MacOS, no anti virus, malware, etc. I’ve installed Dropbox.

About other systems, I’ll try.

Tried closing Dropbox, same results.

Hi @flodi,
I have a test version to try which should hopefully provide us with a bit more information. https://www.odrive.com/s/4ec4c395-f720-4efe-9d36-77b9ced5e8ef-5d01230a

Can you install this and then try to open the Google Drive link? Please send another diagnostic from the odrive menu and attach the “current_odrive_status.txt” file.

Done for both drives. Thanks. Here:current_odrive_status.txt (2.1 KB)

Hi @flodi,
Thanks! This definitely reveals where the issue is occurring, although it still doesn’t make much sense. Google is complaining about the authorization method, but the reason it is giving doesn’t match up with how we are doing it.

I have another idea to try to debug this further. Since you seem to be able to hit this with both of your current Google Drive accounts, I am wondering if you can try creating another Google account for testing. If you can hit the same issue I can try debugging with that account to see if I can hit this issue.

Can you create a test Google account and see if it hits the same problem? If so, can you send me the test credentials via a direct message (click on my name and click “Message”). If I can reproduce this myself I should be able to get to the bottom of it and fix it.

Tried, same problem it seems.

current_odrive_status.txt (3.6 KB)

Hi @flodi,
I sent you a direct message. Can you take a look?

I was facing same problem

Hi @blakegreen286,
I forgot to update this thread after it went over into direct messages. The issue, in this case, was isolated to the computer. The user tried on a similar computer with the same setup/location and the issue was not seen. We weren’t able to determine what was causing it on the machine, however.

If you are seeing this issue, too, can you provide some details and post your current_odrive_status.txt file?