Odrive menubar icon not clickable + odrive not working

@olivier.piasentin and @al_canada I sent you a direct message with a test build and some instructions. Please let me know if you have any questions.

Hi, my Odrive was suddenly stopped working last night. It didn’t sync and there was nothing I can do. The Odrive icon stays in the toolbar but do nothing when I clicked on it.

I browsed the forum and found this script:

killall -KILL odrive; killall -KILL FinderSyncExtension; sleep 5; cd “$HOME”; rm -r “.odrive/bin”; rm “.odrive/version”; open “/Applications/odrive.app”

I did and it worked. Odrive was restarted and asked me to sign in. The moment after signing in, Odrive stopped working again.

I tried to uninstall and reinstall and it’s still not working.

Please help, thank you.


1 Like

Hi @feliz.you,
I sent you a direct message, as well. Can you take a look when you get a chance?

Hi @Tony, thank you for your help. It’s working now.

Thank you.


Great! Thanks for testing that @feliz.you.

Hi same issue here. Running 10.12.6 Sierra on a MacBook Pro early 2011

What is the fix?

1 Like

Hi @sheldon.maye,
Can you give this version a try? https://www.odrive.com/s/e602f11e-849b-4204-b38b-018a971986e4-5ed0a2a0

So, I tried 6689 twice and 6690 twice too.
The Good: in every case odrive is working. The menubar icon works as intended and files sync etc.
The Bad: the finder extension doesn’t work after install. In fact, it only works if I kill the Finder and restart it. Just shutting odrive and restarting it has no effect. Worse, if I restart Finder and everything finally works has intended, quitting odrive then restarting it shuts the finder extension and I have to restart the Finder again.
We’re getting there…

btw, reinstalling odrive respawned two folders tied to gmail accounts that were linked previously. Any chance I can get rid of them?

Thanks for testing @olivier.piasentin! I’ll take a look at the Finder extension issue you are seeing and see what we can do about the lingering Gmail links.

For the Finder extension, if you toggle the odrive extension in System Preferences->Extensions, does it affect the behavior?

A post was split to a new topic: File “syncing” without downloading

I appreciate everyone’s help with this.

Here is a new version that we’re hoping will address the Finder extension loading issues people are seeing. https://www.odrive.com/s/5777166d-c73e-4890-bb99-895836b6ee0a-5ed15c3e

Hey oDrive Team. Looks like I’m part of this new odrive not working club too. I’m running Mac Sierra 10.12.6. Which version of odrive should I try and which process should I try for uninstalling the current version? Thanks

Hi @kimberlykeyton,
I’m sorry you are hitting this too.

Please try the version posted right above your post. You shouldn’t have to uninstall, but let me know how the regular update goes and we’ll see if additional steps are needed.

Success! Thanks for the quick fix.

1 Like

Great! Thanks for confirming @kimberlykeyton.

Here is one more (hopefully last) test build.

This is a tricky issue. We can’t reproduce it in-house, so we’ve refactored some likely areas and hope that it will hit the issues noted so far.

This fix has been officially released in our latest version. My thanks to everyone for their help in tracking it down! :

Just to be clear, I click on this Link then download and install? Will I lose a folder structure or well files have to be re synchro or settings re done?

Hi @sheldon.maye,
Yes you just download and install. It will upgrade your current installation and keep everything the way it was.

Thanks for this update, Mac prod6694. I’ve been having this unclickable problem for a while. Found the uninstall/reinstall instructions and that fixed it for a while, but it always came back. I just installed 6694 and it is working great.

1 Like

6694 seems to have done the trick!

1 Like