Odrive doesn't sync to Microsoft Onedrive


Suddenly odrive stopped syncing files from my computer to Onedrive. The files that don’t sync are stuck in “waiting” mode (tray icon > right click > waiting).

As an exception, files with file size 0 kb are still synced (regardless of file type).
The other direction is fine: New files (also larger ones) created in Onedrive online, are correctly synced to my computer with odrive.
Syncing to Google Drive still works, so it’s related to Onedrive.
My Onedrive is not full, there’s plenty of space.

I’ve already de-authorized and re-authorized my account and I also did a fresh re-install of odrive (according to these instructions).

Is there anything else I can try?


EDIT: I’m on smallband internet since a few days because my limit was reached. This might coincide with the odrive sync issues starting although I don’t see the connection. I’ve tried tethering 4G with my phone and still same issue.


Hi @garfinator,
Can you send a diagnostic from the odrive tray menu?

When you send a diagnostic, a local file is also created in the root of the odrive folder named “current_odrive_status.txt”. This provides some sync information and recent errors. Can you message me that file?

Hi Tony,

Thanks for your help. I’ve sent the diagnostic. I’m able to locate the local status file, but how can I send it to you through a private message so the private info isn’t public? (sorry for the newbie question)

Hi @garfinator,
You can click on my name and select “message” to send me a direct message.

Hi @garfinator,
I took a look at the diagnostic. The error that OneDrive is returning is odd and non-specific, so I can’t pinpoint what the issue is.

Let try this:

This will remove odrive’s access to your OneDrive account. It may take about an hour for Microsoft to expire the active tokens. At that point odrive will prompt you to login to Microsoft again to restore OneDrive access. After reauthorizing, see if the same error occurs.

Hi Tony,

I’ve taken those steps and it asked me to reauthorize, but same issue persists. I’ve sent a diagnostic report in case it’s useful.

I’m having the same issue recently, only with OneDrive. Files are stuck in waiting. Tried reinstalling odrive to no avail, and other providers like Dropbox work fine.

I have the same issue on my MacOS

It gets stucked in the stage: “Waiting” - files that are stored on MacOS cannot get into cloud
However, when I upload them manually via web on onedrive.com the appear in MacOS
So upload NOT ok, download OK


Thanks @garfinator, @odrive3, and @homonto.

I was not seeing this issue yesterday, but I am not seeing it this morning. Microsoft must’ve changed something on their end. Investigating…

true, this is a new “feature” :wink:
unfortunatelly very high prority if not working - potentially we can lose the data ;-(
@Tony, help us please :wink:

@garfinator, @odrive3, and @homonto (and anyone else hitting this), can you try these test builds to see if the issue is corrected? https://www.odrive.com/s/4e51b5db-0309-4348-b5bd-df998600c4eb-5db9bf4b

it looks like it works for me

1 Like

Same here! Fixed. Thanks Tony for your quick help.

1 Like

I have some issue sync file to OneDrive since few days ago. The file unable to upload to OneDrive server, but the download works fine. I tried odrive web version, it doesn’t work as well. All other cloud storage works fine. Anyone can help please?

Hi @tommywkzhao,
Please take a look at the above post:

We’ll try to get this out in an officially release ASAP.

Thanks so much! Can confirm that it works both on my Windows and Mac machines.

1 Like

My odrive has problem in syncing to OneDrive, and all files are in the status of “waiting”.

The local blog current_odrive_status.txt records the exception:exception=ComponentException(code OD_OTHER_ERROR caused by OneDriveException(code OD_OTHER_ERROR - Unhandled status code 400. {“error”:{“code”:“invalidRequest”,“message”:“Bad Argument”}})).

The problem have been existing since 10.29.

Hi @xiangchenhui,

We are releasing a fix later today for this, but you can use interim build in the meantime, if you like:

This fix has been officially released now:

Many thanks. I login Odrive and it Syncs successfully. Thanks for fixing bugs.

1 Like