Multiple Backup Errors from Odrive

Hi, getting multiple errors trying to back up to Amazon Drive using Odrive. macOS Catalina, local folders, cloud folders (full path to a local drive) and an external drive share. Getting errors across each type of backup. Had a look through the forum and could not find anything similar. Also reached out to support but got directed back here. I just get a backup error and a dialogue box stating to look at the logs - which doesn’t shed any light on what the actual issue is. Appreciate any advice on how to resolve this.

Hi @AP1111,
It looks like the support team was engaged with you last night via e-mail. There were a few pieces of information requested for further analysis. Just let me know when you get a chance to do that and I’ll take a deeper look/try to reproduce using that information.

Hi Tony, many thanks, Support has been great. I deleted the backups that were in error and recreated them. Strangely the external backup that was in error works if I create a backup on a per folder level rather than the master folder. A little cumbersome but it seems to work. Regarding the other issues, I have done some testing and it would seem to be a file naming and and file format issue with Amazon Drive not Odrive. I’ll close the support request and rationalise my backup Strategy. The only outstanding issue is the backup of local iCloud folders. MacOS creates a virtual local copy of the files in iCloud and creates what looks like and alias style path to those local copies. These are the files I want to backup but it does not seem possible for some reason. I will keep testing different approaches and see if it is the length of the path causing the issue or the alias. Interested to know if anyone else has tried this with iCloud and what their approach / experience has been. Looking forward to the Apple Silicon (M1) compatible version of Odrive.

Hey Andrew (@AP1111),

I took a second look at this and realized that you were backing up the root of a volume. I missed that on the first pass. We are supposed to prevent this from being done in the first place because it can cause some odd behavior (like the permissions issues you are seeing). You should actually get an error if you try to setup a backup like this. Can you walk me through how you set the folder for backup. My testing is hitting the expected error when I try.

Interesting. If you are able to share the exact naming of an item I can reproduce and make sure we are handling the Amazon Drive error properly. I think we may be lumping the exception coming back with another error, which causes more confusion.

There was another user who was attempting this, as well. He was targeting a folder in ~/Library. We were originally rejecting the ~/Library folder, but we removed it in a follow-up release. There is an image in the thread that shows the location he was backing up: Backup feedback

The current version actually works on M1’s using Rosetta 2, we just don’t have a native build for it yet. This is something we are going to be looking into, but you should be able to use odrive without an expected issues on M1-based systems right now.