Backup feedback

Hi Tony,

I finally had the time to test the new backup feature .
I was able to change the odrive_user_premium_conf file to allow for merging.
I added a folder for backup using the merge feature and it was fine but then I wanted to add another folder and I got an error message (same one that you get if you don’t enable the merge feature - attached screenshot).
If I restarted odrive the folder was added successfully but then adding another folder induced the same error message.

Another thing - the backup log is quite empty when merging - no info regarding the process, I tried to add a file to a folder which is backed up and the file was added to the cloud but nothing is written in the log regarding this.

Last thing - sometimes after adding a folder (merge) nothing happens - the folder is added , the odrive menu icon is idle (black) with no indication of starting to work and only after I choose the option to “run backup now” odrive is starting to work.

thanks again for the hard work .


Hey @leiboavi,
Thanks for the feedback! I’m splitting this off into a new thread to better track the discussion.

The behavior you are seeing is expected in that version, although the next version will adjust things so that you can merge each new backup you create. What is happening right now is that it is disabling “merge mode” after the defined backup jobs have completed successfully. The reason for this is that merging is an expensive process, so we don’t want to do it all of the time.

The next version also has better logging so that you should see all of the activity. I think it should also fix the final issue you are seeing with it not kicking off right away.

I’ll see if we can get it into your hands to try out before the official release.

Again, thanks for the feedback. It is greatly appreciated.

I was wondering.
can’t a folder be synced to one cloud provider while backed up to another cloud provider ?


Hi @leiboavi,
Right now you can backup a folder to multiple providers, but you can’t mix sync with backup on the same folder. Mixing the modes on a single folder has some special considerations and caveats that we need to dig into to determine if it is feasible.

Hi @leiboavi,
We’ve released a new version with several improvements, including logging and merging.

Hi @leiboavi,

Can you provide me with the relevant log entries for this backup job?
Does it seem to just hang indefinitely?

When I check the status it is 0% for a long time . After I engage the backup manually the status is then stuck on 99% forever but in the logs everything is fine and there is a message that the backup is complete.
I also tried to add a file which was backed up just fine

can it be related to the configuration file? I disabled FSevents

I checked also folders outside the iCloud Drive - all went ok - the backup started automatically and all the way to 100%

just after adding the folder :

after engaging the manual backup:

the logs:

Hi @leiboavi,
I see the issue. We are excluding items in the ~/Library folder. I believe the reason for this is because it is generally configuration data and not user files. However, as can be seen in your case, you are backing up iCloud file here.

I will discuss this with the product team and see if there is a reasonable exception we can make here.

Hi @leiboavi,
I forgot to mention that our latest version removes the ~/Library folder restriction, if you want to give it another shot.

It works! , I can now backup from my iCloud Drive folder!

Thank you