Missing Windows Explorer Context Options on Windows 7 with ODrive 6461

After a clean install of Windows 7 Home Basic with all updates applied and all other software working as expected on a friends laptop no context menus show up.
Please advise me what to do.

Hi @andrievorster,
Can you tell me what other software is installed on the system?

There is a local communication aspect to the software where the shell extension (context menus and overlays) talks to the odrive app. If that communication is prevented then the menus and overlays won’t show up. Generally things like endpoint protection, antivirus, malware protection, and other such products that could be monitoring low-level process interaction and communication are the likely suspects.

Does the odrive client seem to be working normally, otherwise?

Hi @Tony,
Google Chrome, Adobe Acrobat Reader DC, VLC, Office 2016 Word and Excel, D-Link Connection Manager, 7-Zip, MyDefrag and UltraCopier.

I use Bitdefender Free as my antivirus, but it is also installed on my laptop and I have no issues.

EDIT 3: I also have MyDefrag, UltraCopier and 7-Zip on my own PC and everything works correctly on my PC.

Yes, the client works normally otherwise.

Thanks for your reply!

I disabled Bitdefender Free and rebooted and tried, still no success.
The enteries are enabled, but they are highlighted red in NirSoft’s ShellExView.

I have tried Deauthorizing and Reauthorizing, reinstalling after complete uninstallation and cleanup (for the 3 time today) and I have checked that the installer runs correctly (with admin rights) all the way through the installation.

Hi @andrievorster,

Thanks for the additional info.

This is normal. There is a setting in ShellExView under Options to “Mark Non-Microsoft Extensions”, which will highlight them in that reddish color.

One thing you could try is creating a new user on that system and running odrive for that user to see if the problem persists.

Do you have other systems with Windows 7 Home Basic on them with the same configurations that work with odrive?

Can you send a diagnostic from the system from the odrive menu?

Hi @Tony,

My pleasure.

Yes my personal laptop has the same configuration.

I sent the diagnostics. I will pm you from what account it is.


Hi @Tony,

I found a (maybe the) solution! For some unexplained reason Microsoft .NET Framework 3.5.1 was turned off in Windows Features. Turning it back on fixed the problem.
Can you maybe implement a check for this service as a patch on the program?
I can’t believe a thing as small as this took my so much time, it should not be necessary.


Interesting. Nice sleuthing @andrievorster!

.net 3.5.1 shouldn’t be required, so we’ll have to investigate this. Thanks for the follow-up and for spending the time to troubleshoot!