Microsoft Surface Pro X issues - Syncing

Is anyone else using an SPX - they run ARM64 which is a problem.

The sync Odrive app works reasonably well but I am unable to work out how to sync local folders and files in the File Explorer app. There is no right click context menu. The system tray does show the Odrive icon and menu but I cannot work out how to register a file or folder for syncing using W10 on an Arm powered SPX.

Has anyone experience in this?

Has anyone experience using this? How do you register a folder and file for synching?

The ODrive program is working and and I have two google drives connected and showing in explorer but I can’t work out how to register a file or folder for auto-synch?

  1. There is no right click context option for syncing a file
  2. There are no Odrive right click options at all in fact in File Explorer. (as per this pic none of the pink options are availabe in a right click view)

The system tray does show ODrive.

Hi @smithpetermark,
Unfortunately we don’t test against ARM64 for Windows (or specifically build for it, for that matter).

Does double-clicking to open files and folders trigger syncing those items?

There was a somewhat crude alternative for right-click syncing that I hastily made a while back. It may be usable in this situation:

Yes Tony - double clicking does work to sync ODrive.

See pic. I double clicked “business case” and it synced while the others haven’t.

However there are no right click ODrive menu options.

I’ve not yet tried your fix but it doesn’t seem relevant.

Hi @smithpetermark,
Thanks for the response.

It’s not really a fix, but a workaround. It is supposed to create an alternate right-click context menu option that can be used to right-click sync files and folders.

It is definitely possible that our default context menu is just not compatible with ARM64. I don’t have a system like that to test with, unfortunately, so I am not able to debug it.

The Sync option now shows in the right click menu after using your work around.

I’ve “sycn’d” the 00.Odrive Test folder but can’t see where it has sync’d to in order to test it is syncing. Any hints?

The second option (.inf file) crashes on install.

In addition the System Tray “ODrive” menu still does not show any files or folders as registered for syncing.

Hi @smithpetermark,
I misunderstood. You want to use the “sync to odrive” feature.

Since the CLI was installed with the workaround, we can use that to create the “sync to odrive” folder. For example, based on your screenshots above:

  1. Open up a command prompt window by clicking on the Windows icon in the taskbar, typing “cmd”, and then clicking on “Command Prompt”.

  2. Enter a command like this:
    "%userprofile%\.odrive\common\odrive.exe" mount "C:\Users\Peter Smith\Documents\00. Odrive Test" "/CRX/00. Odrive Test"

The example above would create a “sync to odrive” relationship between your local 00. Odrive Test documents folder and a remote folder named 00. Odrive Test in the linked storage you named “CRX”. The remote folder would need to exist prior to running this command.


On the SPX now upgraded to Win11. Good news is that syncing and backup options are now showing in the right click context menu and running.

The only bugbear left is that the folders don’t show they are “O Drive sync’d”. I can probably live with that.

Hi @smithpetermark,
Thanks for the update. That is very interesting. So the context menu options are showing, but not the icon overlays (green checkmarks and pink circles)?

Actually better than that. Clicking through the ODrive folder in explorer shows the sync’d and unsync’d items fine. However the main explorer left side does not show sync status but I’m not sure if it is meant to. W11 definitely improves it all on SPX the the point (once I’ve gotten more comfortable that it is really working against some work folders) that I’ll subscribe.

This is clicking into a GDrive on the ODrive folder. GSPE is sync’d. The 2016 pic is sync’d. Nothing else is (which is correct - show as cloud files).

There have been some issues with the system tray messages complaining about not being able to sync but seems to be getting better. Maybe a bandwidth issue.

Hi @smithpetermark,
I see. Thanks for the images. I don’t see the icon overlays, so that is not ideal, but you are right that you can tell what is a placeholder and what isn’t based on the file type.

For the sync errors, if you continue to see them you can send a diagnostic from the odrive tray menu and I can take a closer look:

Tony - I send a diagnostic report. I’ve not seen the errors this morning.


I’m still Beta testing but I’ve found the ODrive solution to be pretty solid now on my SPX running Windows 11. I’ve not tried back up but I’ve been able to move a lot of my dropbox into google drive easily (just dragging folders over from dropbox to google) and that has been a real help.

I’m looking now at syncing to a work google account.


1 Like

Great! Thanks for the continued feedback @smithpetermark.

Tony - the latest build has some strange effects - the context menu has disappears from the system tray ODrive icon. Still investigating it. Can you extend trial for a few more weeks so I can log a report - (sorry busy with normal work most days).

Hi @smithpetermark,
That is odd since we didn’t change anything with the tray menu or context menus. I will follow-up in a direct message.