Getting "index.xml file is missing" message

When trying to open some .numbers or .pages files, I get a “x file is invalid. the index.xml file is missing”. I have no idea what that means. I’ve experienced this problem with files that were originally put into my odrive folder on my Mac Mini (desktop) and later synced to my macbook. when trying to open some of the .numbers and .pages files, I got the above message. this happens with some .numbers and .pages files but not all. Any help is appreciated.

1 Like

Generally these Apple file formats are package files, which are actually directories full of files. It is possible that you may need to right-click on the file and select “sync”, which will bring up the folder sync dialog. You would then slide to “Everything” and check “include subfolders”

Can you give that a shot?

Tony, I right clicked on the file in question and the odrive options include an “unsync” option along with “Share Link” and “Copy share link to clipboard.” So there’s no “sync” option.

Did you recently upgrade OS X? Do you find that the same files work on other machines, or are they displaying this error on all machines?

I did a little searching and it sounds like it can happen with conflicting versions of the applications, where older files cannot be opened with the newer apps and vice versa.

For example:
"OK, I think the mystery is solved. Evidently, with the upgrade to Yosemite, I also got an upgrade to Pages v5.5.2. It appeared separately in my Applications folder and I just never noticed it. The older '08 version of Pages appeared in the Applications/iWorks folder; it was this older version that I kept trying to use to open the Word files I transferred from my PC. Once I ‘discovered’ v5.5.2, I could read my Word files with no problem.

With the Yosemite upgrade, I also received Numbers v3.5.2 and Keynote v.6.5.2."


My Mac mini has the updated OS and the files work there. My MacBook has the old OS and the files have the problem there. So I assume that updating the OS on the MacBook should solve it?

I think that is a possibility worth investigating. Apple seems to have created compatibility issues between their formats and their versions of the applications.

Please let us know what you find.

Most frustrating problem yet. Problem surfaced first time yesterday on a single Numbers file. “The document “Index.Numbers” is invalid. The index .xml file is missing” Running in Sierra, Numbers 2009. Tried previously recommended fixes and turn ICloud off and then back on, and restarted.

Hi @steve.eastwood1,
After you performed these steps:

Are you able to go into the Index.Numbers package (right-click->“Show Package Contents”) and see if the index.xml file is there?

Hi, If you get the missing index.html issue, it means the file was once syncing to iCloud. To open the file again, login into the web account (or any iCloud account) and then upload the file. It will open and from there you can download in any format - it will be fine,


Martin 1 is a genius. You nailed it. Found my file and was able to not have to recreate it. Can’t thank you enough for your time…

1 Like

Hi, yes Martin1 is correct you can also right click the file and open it under the default numbers and not Numbers 2.0 which is the newer version. Good luck guys


ggeronimojr, thanks! That right click and opening under the former version of numbers worked very well. I did recently update my numbers as prompted and that’s what made the file say invalid, xml missing. We don’t have to worry about hackers and malware, the apps do it to us already!