Ftp & sftp not working (cpanel)

Hi guys,
I am unable to gain access to my ftp / sftp which is sitting on a whm / cpanel server.
The messages I get are:

sftp:
Unable to sync SFTP_****.cloudf.
Your credentials are not valid to access this service.

and ftp:
Unable to sync FTP *****.cloudf.
You do not have sufficient permissions.

The response is pretty immediate.
Why I think this is an issue:
I can log in with the same credentials with filezilla immediately (I do get the “this certificate is unknown” though)
and I can login to the sftp with an ssh client immediately with the same credentials, and private key.

Please help me figure this out.

Hi @roiezra1,
Can you send a diagnostic from the odrive menu so I can take a closer look?

Is it possible to create a test user I can try?

Hi,
Sure I sent a diagnostic, & sure I can create a user for you. how do I send you the information?

Hi @roiezra1,
The diagnostics give a bit more info.

For the SFTP error, it is complaining that the private key file is encrypted. Did you provide the passphrase for it in the SFTP link information?

For FTP, the error coming back is that it can’t change directory to /usr/local/apache/domlogs

so for ftp:
I am not sure why its trying to change the folder to that???

for SFTP:
its not encrypted: I am even trying to login via another ssh client and nothing!

how do I solve this? please help me.
Also - where do I see these logs on my machine?

by the way - I see this is a similar issue that also was not resolved


it works on some ftp and sftp - but not on any server that has whm or cpanel. not on my dedicateds and not on my godaddys.

Hi @roiezra1,
I am able to browse FTP with the credentials you sent me from the odrive desktop client. Can you try linking ftp with those credentials and see if you are able to browse?

Hi @roiezra1,
I think the FTPS connection is failing because of session reuse, as in post you referenced above. FTP seems to work okay for me using your test account.

For SFTP is there an account that can be used to test?

Can you clarify what you mean here?

Hey I got the ftp to work. For anyone trying to achieve the same thing with a WHM or Cpanel server:
The answer is that the ftp cannot start higher in the directory of the account than public_html directory position.

@Tony You were right. it the key was encrypted for the sftp - and I added the password but still, it isn’t not working.
What I tried telling you before is - in another ssh client that account I am using is working.

now the error is:
Unable to sync SFTP.cloudf.
You either do not have permission or the filename contains illegal characters.

The reason the sftp may not work can be also the same as why the ftp didnt work.
the ftp could not start at /home/user_name/
It had to start at /home/user_name/something

Thanks for that insight @roiezra1. Do you have both SFTP working now?

no not yet, I sent you a diagnostic to check why this is happening, and how can we bypass it. it would be really helpful to get it working.

Hi @roiezra1,
I took a look and the SFTP server is returning a generic “Permission denied” exception when trying to list the folder. Did you try setting the start path to a specific folder, like “/home/username/folder”? The SFTP connection defaults to / so that may very well be the issue.

you cannot move the specific user directory (thats how the cpanel architecture works - /home/username/everythingEsle )- but on other ssh clients everything is working fine. I guess there is an issue with this feature and cpanel servers. maybe look into this? It would be really nice to resolve since that user and key do work with putty. in the mean time I will use ftp since I got it to work, but I would prefer to use the ssh (sftp)

Hi @roiezra1,
Unfortunately I don’t have access to a cpanel SFTP configuration, so I am not able to test this.

What I meant for the configuration change was to change the path in the odrive link configuration. It provides a “Start Path” parameter. If you could change that to the path where the folder is on the server, that could work. After the change you will want to restart the odrive desktop client.

That would have been a nice idea - but it didnt work. I put /public_html there.

Hi @roiezra1,
The SFTP path starts at root (/) by default, unless the server is setup with chroot, which I don’t think cpanel is. This means you would have to specify the full path to the public_html folder (something like /home/[usernamehere]/public_html).

If there is a test account I can try, I can investigate more if this doesn’t work.

Success! haha it worked. Thank you
I guess its the same concept of the ftp with cpanel servers.

Thank you!

Great! Thanks for confirming @roiezra1.