Finder extension (right-click menu) missing in MacOSX 10.11

It came back with:

  • com.oxygen.odriveapp(1.0) 08027327-6CD8-4B69-9E39-FA9837BF7FA7 2016-06-23 08:36:42 +0000 /Users/fara2/.odrive/bin/5491/
    remove: no plugin at /Users/fara2/.odrive/bin/5491/
  • com.oxygen.odriveapp(1.0) E961C312-4402-416E-B079-60948BD66A12 2016-06-23 08:41:29 +0000 /Users/fara2/.odrive/bin/5491/

This looks correct. OS X is telling us that the extensions are registered properly. :confused:

You do not see them listed in System Preferences -> Extensions? Can you take a screenshot of the Extensions panel for me?

Can you also try logging in as the Guest account, running odrive, and seeing if the extensions are loaded there?

You can enable the Guest account here:

You can also enable fast user switching here, so its easy to switch over and test:


Getting into that in the guest account requires turning off file vault and decrypting my files. That’s just too much trouble to go through at this time. I will just stop using odrive for now.

Sorry we couldn’t get this working for you. I can’t tell why this is happening. All of the steps we are taking indicate that the extension is installed properly…

Just let me know when/if you are up for working through it a bit more.

I had this problem in a Win10 machine, and now in OSX 10.11 . What is going on? I want my context menu back, please!
(i have tried the above terminal commands, to no avail. Terminal tells me the extension is installed, but it does not appear in the System Preferences Extensions panel.)

Does anything appear in the system preferences extensions panel? Have you been able to try the above test with the guest user?


Nothing in the Extensions nor in Guest. Screenshots attached.

This one has me stumped. I guess one more thing we can look at is the console to see if there are any messages regarding a failure to load extensions. When you take a look, does anything stand out?

Did you see this post above?


This link’s solution ( has solved the issue. I just hope the problem did not happen in first place.

Glad to hear! This seems like an issue with OS X where it’s caches get screwy…

I am having this problem as well.

The Odrive app is not downloading the extension at all. The plugin folder inside the is empty, in my case.

Hi @desalegnbw,
You are running MacOS 10.11?
Do you see the odrive extension listed in the MacOS System Preferences -> Extensions?