Error - "Can't sync - No permission"

I need help because I don’t now how to fix this problem. This message "“Can’t sync - No permission” appears when I try to Sync any folder with Odrive.

This message appears only in my PC. The same thing don’t happen when I use the Odrive in my notebook.

Help me, please!

Hi @raulzaomarista,
Can you trigger this error again and then send a diagnostic from the odrive menu?

This happens on all of the folders in odrive, including the ones that currently show checkmarks next to them?

Ok! I send a diagnostics.

Yes! It’s happening on all of the folders in odrive, including the ones that currently show checkmarks.

The Odrive was ok when I installed the software and used it for the first time on my PC. This problem only appears after I switch of my PC and connect again.

This checkmarks appears because I used right after the installation. But, after I switch of my PC and connect again, I can’t Sync anything.

I tried to unninstall and reninstall again, but the same problem happens. It’s ok only right after the installation.

Hi @raulzaomarista,
I took a look and the error is coming from Windows. Basically Windows is not allowing odrive to write to that folder/drive and returning an “Access Denied” error.

Can you tell me what type of drive this is on? Is this an internal drive, or external/networked drive?
Are there any special permissions you have applied to the folder/drive?
Could there be a permission that is blocking writes to that location?

I have a SSD and a HD. The Windows is on the SSD, and the Odrive on the HD.

I don’t know how to explain about any special permissions.

I tried to install as administrator to check about any permissions too, but It didn’t solve the problem.

Can you tell me where I need to look on the Windows to check about this permissions? I don’t understand very much about it.

The “Backup and Sync” from Google Drive is on the HD too, but It is ok, without any problem.

Hi @raulzaomarista,
Can you take a screenshot of what you see when you right-click on the E:\Odrive folder and select properties->security->advanced?

One thing we can try to see if it might be something strange with the E:\Odrive folder is to deauthorize and the login again to start fresh. To do this perform the following steps:

  • Open the odrive menu and select Authorized User -> Deauthorize
  • Confirm that you want to deauthorize
  • Log back in to odrive by following the “Welcome” screen.
  • Rename E:\Odrive to E:\Odrive-backup

This will reset the odrive settings and create a new odrive folder in C:\odrive.

  • Now you can select Move odrive folder from the odrive menu and select E:\ as the destination.

This will create a new E:\odrive folder. See if odrive is allowed to sync folders.

Sorry! I´m back after a vacation.

The problem continues even after I have done the indicated steps.

Hi @raulzaomarista,
Let’s try to change the owner of the folder to you instead of Administrators:

Click on Alterar at the top where it shows Proprietario

The rest is in English, sorry! :slight_smile:

  • Now click on “Advanced”
  • Then click on “Find Now”
  • Find your user name and click OK.
  • Click OK again
  • You should be back at the Advanced security settings screen, like in your screenshot.
  • You should be listed in the Proprietario section and there should be a checkbox under that asks if you want to replace the owner on the subfolders and files. Check this box and then click on Aplicar
  • Click OK

This will change the owner of the folder to you and should hopefully provide the permissions we need.

It’s ok now! I can use the odrive. Thank you!

Great! Thanks for the follow-up.