Error updating the file. No permission

Hi, I just set up odrive desktop client to a new lapbook bought for my daughter (it is a Chuwi GemiBook running Windows 10 Home).
I use odrive to link three accounts: Google Drive, Droppbox and OneDrive for business. Installed it and worked like a charm for a while, but now it stopped syncing. It says “Unable to sync <file/folder name>”, an all three accounts. Obviously no apparent configuration changes made.
On other PCs and on the web odrive link to the three storage spaces works fine, even from web on the PC with issues.
I also tried refreshing subscriptions but nothing happens.
I haven’t tried to downright uninstall and reinstall the client but I can if needed. I thought to write here before, in case you can give me some better advice.
Many thanks in advance

Hi @luca.andena,
Can you reproduce the error and then send a diagnostic from the odrive tray menu? I will take a look and see if we can figure out what is causing the error.

Hi Tony, I just did that. I’m also attaching the log file.
Many thanks in advance,
Lucacurrent_odrive_status.txt (5.0 KB)

Hi @luca.andena,
odrive is reporting a permissions issue when trying to delete the placeholder file and replace it with the “real” file.

Take a look at this post here for a similar issue and how it was resolved. See if the same instructions will resolve your issue:

Hi @Tony,
that did not work. However, I noticed that the CREATOR OWNER user did not seem to have full control of the folder. I gave it full control over the folder and now it seems to work.
Strange because right after installation everything was running fine, even after I moved the odrive folder from the Windows to the data partition.
I’ll keep you posted should the issue come back for any reason.
Many thanks

1 Like

Thanks for the update @luca.andena!

Somehow the permissions must’ve changed on that drive at some point. I’m glad you were able to figure it out.