Encryption/unable to change password?

Hi all,

I just upgraded to Premium, trying to give it a shot!

I created a encrypted folder with password of “A” on client A , I created example.txt.
On client B I accessed the same encryptor folder and purposely typed in the wrong password “B”, I also created another random.txt file.

Client B’s odrive opened the encrypted folder, and I was unable to see the example.txt from Client A whatsoever, not even the garbled encrypted version of it.

I figured no big deal, I just unsync, and resync to enter the correct password? Nope, didn’t work. Client B will not let me insert correct password.

Can the devs clarify what is going on? It seems unfair that we can type in the incorrect password, if we make a mistake this hoses everything, also very strange that we can’t see encrypted/garbled versions of the files with the wrong password, yet they are visible in storage provider/Google Drive.


Hi @carlco,
You should be presented with a different dialog if you already have encrypted content in an Encryptor folder. This happens because odrive looks at the contents of the folder when you expand it and if it has a file or files that carry an odrive encryption signature, odrive will prompt for the proper passphrase to decrypt that detected content.

If odrive looks in the folder and doesn’t see any files that have an odrive encryption signature, it will assume this is the first use of the Encryptor folder and prompt the user to set the passphrase.

If an Encryptor folder is expanded on each system before adding any encrypted files (or before they have synced), and each system uses different passphrases, then those two systems will use the passphrase given to them from that point on. You will end up with two different encrypted sets in the same folder.

odrive is programmed to only show the files in an Encryptor folder that it is able to decrypt, which is why you do not see the files that are not encrypted, or encrypted with a different passphrase. If you want to see the raw files you can navigate to those areas with the standard folder hierarchy instead of the Encryptor folders.

It is not expected that you would be able to enter the wrong passphrase if there is already encrypted content in the Encryptor folder (See my post here on what we expect you to see: Update documentation about not possible to change Encryption password). If you were able to do that then it sounds like a bug, or a case where the files were new enough that they were not fully synced yet and some sort of race condition was encountered.

If a case like this does happen you can purge the stored passphrases on the system in these locations:

Windows registry:
HKEY_CURRENT_USER\SOFTWARE\odrive-encryption-[unique uuid] where [unique-uuid] is a different ID for each encryptor folder that has been setup.

Mac keychain:
Under odrive-encryption-[unique uuid]

Thanks, and sorry for the delay.

I tried again later, and it worked as intended, and DOES fail when I use the incorrect password.

1 Like

Great! Thanks for the follow-up @carlco.