Directory not sync'd

I have a directory within my ocloud folder which exists on my local drive but not in the cloud backup. How do I get it to upload and sync?

Hi @tenuki57,
Can you send a diagnostic from the odrive menu and let me know what the name and path of the folder is?

Additionally, when you send a diagnostic, it creates a file in the root of the odrive folder named “current_odrive_status.txt”. Inside are some details that may point to the issue, too. Can you attach that file here?

I use Linux so I can only use the CLI - how do I send a diagnostic?

Hi @tenuki57,
We don’t have the diagnostic in the agent yet, but it is something I want to get in there soon.

Can you tell me the name of the folder that isn’t syncing?
What happens when you refresh that folder?
Does status show anything in waiting or not allowed?

The folder is called ‘Training’. It is a top level directory under the odrive folder.

When I refreshed it, the first message was ‘Not Synced’ and then the directories and files in the folder were listed.

When I tried to sync, I got the message ‘Unable to sync Training. Please use a placeholder path.’

When I do a status report, it says

Sync Requests: 0
Background Requests: 0
Uploads: 0
Downloads: 0
Trash: 72
Waiting: 0
Not Allowed: 15

Hi @tenuki57,
The only folders that can be at the top level, in the root of the odrive folder are storage links (Amazon Drive, Dropbox, Google Drive, etc.). The root of the odrive folder is not backed by any storage, so you would need to put the Training folder inside one of your linked storage folders.

If you use the command status --not_allowed to get a list of the items that are in “Not allowed” and why they are not allowed to sync.

I think I misled you. It is a top level directory under the odrive folder on my machine at home. It is in the linked storage folder, and there are lots of other folders at the same level which are being synced.

All the ‘not allowed’ files are Google Docs, which cannot be edited on my local machine so there is no point in downloading them and no problem there.

Hi @tenuki57,
If you make a copy of that Training folder and name it something else, does it also not upload?

What about create a test folder with a couple of files in it, alongside the Training folder? Do they sync, or are they stuck , as well?

I can create new directories which sync okay. Have done it several times. Just realised that this one doesn’t sync. I can try creating a new directory and copying the files, but had hoped there would be a way to force odrive to recognise there is a folder here which needs to be uploaded …

‘Training2’ created and a sub-directory and file copied successfully - all uploaded fine.

What if I rename the current un-synced ‘Training’ to, say, ‘Training-old’ and rename ‘Training2’ to ‘Training’, then move all the remaining directories and files into the newly created and renamed directory?

Hi @tenuki57,
Yes that should work.

I was hoping the copying to a new folder would reveal something about the folder contents that was causing a problem, but it doesn’t look like that is the case. I am going to push to get the diagnostics capability into the agent so we can get more details on an issue like this. Right now I don’t have anything to explain why odrive was not picking up that one particular folder.

For what it’s worth, I’m confident it wasn’t the folder contents. Not unless something has got horribly corrupted, and one corrupted file can prevent the folder it’s in being recognised and syncing.

Hi @tenuki57,
I agree. The fact that you were able to copy in the contents shows that it was something else causing this. Just let me know if you run into again and I will push on getting the diagnostics into the agent to provide some better troubleshooting.

I now have a file that is not sync’d. Do you want me to create another topic?

I did some diagnostics …

paul@paul-1005HA:~/C/SG$ /home/paul/.odrive-agent/bin/odrive refresh .
paul@paul-1005HA:~/C/SG$ /home/paul/.odrive-agent/bin/odrive syncstate SG_Particles_People_Purpose.odt
Not Synced
paul@paul-1005HA:~/C/SG$ /home/paul/.odrive-agent/bin/odrive status

odrive Make Cloud Storage THE WAY IT SHOULD BE.

isActivated: True hasSession: True
email: accountType: Google
syncEnabled: True version: prod 868
placeholderThreshold: neverDownload autoUnsyncThreshold: never
downloadThrottlingThreshold: unlimited uploadThrottlingThreshold: normal
autoTrashThreshold: never Mounts: 1
xlThreshold: never Backups: 0

Sync Requests: 0
Background Requests: 0
Uploads: 0
Downloads: 0
Trash: 4
Waiting: 0
Not Allowed: 0

The file (“SG_Particles_People_Purpose.odt”) is nearly up to date, probably to the penultimate time I saved it. I suspect that I saved the file for the last time then suspended the machine before odrive could sync, or before it could sync completely . But then when I started up the machine again, I imagine that some part of odrive doesn’t realise that the sync is not complete, even though another part knows that the two versions are out of step.

1 Like

Thanks for submitting all of this information @tenuki57. We’ll need to do some digging to see what could cause this type of behavior. If you make another edit to that file (add a character, for example), is it picked up, or does it stay unsynced?

I updated the file an hour and a half ago, and the updated file has not yet been synced to the cloud. Have just re-run the refresh and syncstate commands and got the same results.

Hi @tenuki57,
I haven’t been able to reproduce this type of behavior in my testing yet.
This is against Google Drive storage, correct?

I noticed that the version number shown in the status screen (868) is an older version.
Are you running the 32-bit Linux agent or 64-bit?

Can you update to the latest version from the download links here?

Are other files still uploading in that same folder, making this the only file that is experiencing this behavior?

Yes, it is Google Drive.

Other files upload happily from that directory.

I believe that machine is running 32 bit.

I will update the software, but not in the next few hours … happy new year!

If one bit of your software reports that the file is synced, and another reports that it is not, I would try looking at the difference between those two tests to identify what the problem is, which might point towards how to reproduce it.

From my perspective, a reasonable fix would be to replace the test which is not working by the test which is working, but I’m sure it’s not that simple …

Sorry - can’t help it. Used to be in software development.

1 Like

Happy New Year @tenuki57!

The version you are using is pretty old (over 2 years, I believe), so grabbing the latest may address the issue, since there have been several enhancements and fixes within that time. When you get a chance to do that that test again, please let me know and I will relay the information back to the team.

Also, if you are able to use the 64-bit version on that machine, I would recommend using it vs the 32-bit (of course, this won’t be an option if the machine is 32-bit only).