Can odrive work with NAS drives?


I have my files on a NAS and I want to sync them with Amazon Cloud - I don’t want them on the NAS and to have oDEsk also store them on the PC that is running the odrive client…


We offer a way to sync external storage with our “sync to odrive” feature. You can read more about that here:

Are you wanting to get rid of your NAS and import all of your data to the cloud, or are you looking to back it up to Amazon, keep the NAS and the data?


Keep the NAS and sync to Amazon…


Full-time, bidirectional sync can be a pretty heavy process against very large external repositories (like NAS) and most of the time NAS users are wanting to just backup instead of use full sync. For that case, we are working on a backup feature that we hope to release soon.

In any case, take a look at our “sync to odrive” feature and see if it might fit your particular needs:


I have a Win 7 PC with a WD MyCloud NAS. The shares are mapped network drives and I can navigate to folders on the NAS.

However, when I right click on the folder there is no odrive action available.

Am I missing something?


I have verified that copying is possible with rclone. It does have the oddity that it works when the network name is spelled out (\abcd) but not with a drive letter that \abcd\ is mapped to.

With odrive, I don’t see the odrive option whether I use file explorer to browse to the network location or to the mapped drive.


Hi @jss087,
odrive won’t work with UNC paths (\server\path\to\share), but it should be showing the right-click options with a mapped drive letter. You are not seeing the right-click options after mapping the share to a drive letter?


That’s right, odrive does not show in the right click options.


Do you see any odrive menu items listed, or it is completely missing any options? Can you tell me the path you are right-clicking on? (ex: Z:\mydir)


I have the exact same issue. Testing ODrive to see if it is a viable way to get music and video files to my amazon drive. WIN10PRO. WDMyCloud. Mapped Drive Z:


Hi @dadofroo,
We have never been able to reproduce this, unfortunately, so I don’t know what causes it, but I know it can happen.

Out of curiosity, if you map the nas again, on a different drive letter, is it also missing the sync option? How are the permissions set for that share?


I also have this exact same issue. Currently testing during 7 day trial to see if it will suit my needs to sync content that is on my external drives to Amazon Cloud.

I have tried mapping the WDMyCloud to a different drive letter but still no option to sync with odrive when right clicking on the folder.

Any ideas?


Hi @mike.dowsett,
Can you take a screenshot of Windows Explorer when you have the right-click context menu up on the folder you are trying to sync?

The determination for showing the option is pretty simple on the odrive side. odrive is just asking Windows if the object selected is a folder and is it outside of an odrive folder. I just ran a bunch of additional tests on my side, but I can’t figure out a way to cause the menu option to be missing on a network mount.


Hi @Tony - Problem solved.

I completely unmounted the mapped external drive. Rebooted the PC and then remapped and everything is now OK. Sync to odrive now appears in the context menu when right clicking on a folder within the mapped external drive.

Thanks for your help.

Sync network drive

Great! Thanks for the follow-up @mike.dowsett.

I wish I knew why this happened in the first place, but at least we have a potential solution now :slight_smile:


Hi, is there a solution for MAC Users on this? we use UNC paths for mounting remote servers.


Hi @emilio.moreno,
If you are mounting a remote drive, it should be listed under /Volumes/. From there you should be able to use “sync to odrive” on that path.