Amazon uploads stuck

I’m trying to upload files to Amazon but the sync feature seems to be stuck. The uploads get to about 98% then it just skips to the next file not having uploaded and this is just a continuous cycle.

I’m on the latest build of Odrive 6083, I have tried deauthorizing and adding back to no avail. This is on Windows 10, can somebody have a look at my diag file and let me know what’s going on. everything had been working fine for quite a while.

Hi @n1ppy,
Did you send a diagnostic? Unfortunately I can’t find one for you.

How large are the files that are failing? Are smaller files working?

I hadn’t sent it yet, I will send it through now.

Its just a bunch of mp3 files of various sizes but nothing too big. For the record I have a 40mbs upload speed so have plenty of bandwidth available.

ok I’ve sent through a few now.

So there errors being hit are timeouts, where Amazon is not responding in time after we make a request.

Are you seeing that the files make it up eventually?
How long are the individual files sitting at 98%, when you are observing this?

This is the second time I have experienced this but the last time was a smaller file size so wasn’t as frustrating. I’ve been uploading an 8GB file over… hmm the past 12 hours. It reached 99% when I last checked and so the celebrations began. A few mins later it was showing 1% and now 3. So, it’s starting the whole cycle again. Why would this be happening? Last time the file size was just over 100MB.

I moved your post to this topic, since it sounds related.

Are you using Amazon Drive also?
Can you send over a diagnostic so I can take a look?

I am wondering if Amazon Drive is having any issues with uploads. In n1ppy’s case, above, I am seeing timeouts.

Hi @Tony I am indeed using Amazon Drive. Doing the uploading on a Mac. And will send a diagnostic right now for you. Thank you.

Hi @aspin002,
I see a few things.

  1. Amazon is failing on some of these uploads with a “Cannot complete upload” error. That is all it is sending back, so I can’t say why they can’t complete the upload, but it sounds like an internal error occurred.

  2. Network exceptions (broken pipe). This can happen for a number of reasons, but most likely indicates that the connection is being severed somewhere upstream.

  3. Are you copying some of these files in from a network volume? I see some files are increasing in size after sync starts. Usually this happens when the file is picked up by odrive before it has finished its copy (when users are copying files from some other place, for example). If you are copying items in, it may be best to stop odrive until that copy operation is complete.

1 Like

They used to eventually make it but recent behaviour shows that they never get uploaded.

They can sit at anything between 93-98% for a few seconds to about a minute, before moving to the next file. Obviously in terms of bandwidth I can check after an hour and about 10gb was sent but nothing “actually” transferred. Very frustrating!

Since you had better luck before, I am hoping that perhaps this is a temporary thing with Amazon Drive. I also wish they would release their upload resume API…

Unfortunately at the moment nothing is going up at all, what do you suggest?

Thanks for such a great reply. I think it’s the fact I was transferring files to my Mac from an external drive whilst it was still syncing. I’ve been stopping and starting since last night and large files have synced fine. Fingers crossed.

Is this still with only large files? You could send another diagnostic and I can see if it is still the same issue.

We have our IFS feature (split files) that will split files up into smaller chunks that odrive can still access as if it was a single file, but I am guessing you want these files to all be “whole” on the destination storage.

Good to hear @aspin002! Thanks for the follow-up.

Tony - update

So I created a new Odrive folder on the same volume and then manually moved all the folders and files. Lo & behold the synching kicked off again, everything seems to be working again and I’ve had constant uploads for the past 3 hours. Albeit only one file at a time even though average size is only about 8mb, I believe this a limitation of service right and now and you will be introducing controls for threads later?

A little bit frustrating that only a tiny bit of total bandwidth is being used but I’ll take that over nothing!

I will keep you updated on progress tomorrow.

Hi @n1ppy,
I missed this post previously, but is everything still running well?

The single threads limitation is something that will be improved in upcoming versions.

Hi Tony,

So things definitely improved but it was only short lived. The problem reared its ugly head again!

But good news, after further investigation I finally found the offending software. I use software to monitor the network throughput on my machine called NetWorx (was freeware till this month) along with NetLimter 4 to throttle usage.

It so happened as soon as I killed Networx app everything was perfect. So for some reason this was killing uploads towards the end of transmission.

Thanks for your help and hopefully this may be useful for someone down the line!

Very interesting. Thank you for the update and the detective work!

Hello again, everything had been running so smoothly. I now always ensure odrive is turned off before moving large files over and then starting it up. And it’s been great. But I’ve been uploading a huge file over the past 24 hours. And really frustratingly it’s gone back to uploading it all over again. I’m going to send a diagnostic right now.