500 Internal Server Error trying to connect to OneDrive for Business

I have seen that MS can be very frustrating when you have multiple account types and things get confused between the different accounts.

@mtarmour Can you try logging out of all MS accounts via MS’s web applications, then linking your OD4B account again? If it still fails, please tell me the precise time that you submitted the link request. We can see if there is anything in the logs re: this.

Tony -

I signed out of the OneDrive app on both my Mac and my work PC as well as my iPhone and iPad.

I just now tried to add OneDrive for business (11:20am MST) from FireFox on my Mac and receved the 500 error before even getting to a authentication screen.

Thinking there may be a caching problem - I opened a fresh browser instance (Safari this time) and tried to add my OneDrive for Business (11:23am MST) and got to an authentication screen, entered my credentials, and then received the 500 error again.

Thanks. Can you also provide a screenshot of the error you are seeing?

it is only text: 500 Internal Server Error. The server has either erred or is incapable of performing the requested operation.

Thanks. I found a trail. I’m following it now.

@tony - any update on this?

We found an issue. Actually, an unexpected return from Microsoft that we need to handle. The fix should be in soon, but it may not get you closer to linking because OD4B is not returning the needed info to connect. I am going reach out to Microsoft about it.

Good Morning. I haven’t seen any updates on this so I thought I would try to add my OneDrive for business space again. While it does not error out - it still does not add to my odrive account. I goes all the way through the authorization process and still nothing. I even tried removing my personal OneDrive to see if that was the error. I tried to add my OneDrive for Business account with firefox and safari with no success.

There are two issues regarding linking that we are currently working with Microsoft on. The causes are still unclear, but they are looking into it.

Hi Tony,

what is the status on this thread as I seem to be getting the same issue with Office 365 through Go Daddy when I try to connect it to odrive it doesn’t work.


Hi Max,
Can you try linking again and then tell me the specific time it was attempted? I will see if I can pull anything out of the logs.


I just tried it at 2:46 pm EST

I took a look and OneDrive is not returning essential information to us when authenticating. I have submitted an issue to the OneDrive team. Hopefully they will respond and tell us what is going on there.

For the people that were seeing this issue, is it still happening? I finally got some movement from OneDrive on this.

Concerning OneDrive for Business through GoDaddy … see this newer thread at GoDaddy OneDrive for Business. What am I doing wrong?

1 Like

Hi, I’m having the same issue. I’m not using GoDaddy, my OneDrive edition is the one for education, the authentication is using SAML, is this the special authentication you’re talking? SAML is standard for federated logins used in multiple universities (at least in Europe).

Hi @nunomcruz,
We implemented the OAuth 2.0 flow as per OneDrive’s spec.

I was able to have the ops team take a look at your issue and they found your attempt to link OD4B in the logs. It is a similar issue to GoDaddy in that OneDrive is not returning the proper token to us, which means we can’t move further in the process.

Can you tell me a bit more about the OneDrive edition you are using? Is this “Office 365 Education”?

Hi Tony,

Yes it’s the office 365 education. I don’t think that being the education edition makes any difference because I have another office 365 education linked successful to my odrive. The difference between both is that the successful one uses the Microsoft connectors and the uncessful doesn’t. I’m also the person in charge of the saml identity provider and the admin of our office 365 account for the unsuccessful case if you want to debug anything on my side I’ll be glad to help you.

Hi @nunomcruz,
If you can provide a test account that we can use, I can raise this as an issue for investigation by the integration team. If that is possible, please PM me the details. Thanks!

I have the account ready for you but I can’t seem to find how to PM you…