500 Internal Server Error trying to connect to OneDrive for Business

When trying to connect odrive to my OndeRive for Business office 365 storage I get the following error: 500 Internal Server Error. The server has either erred or is incapable of performing the requested operation.

I have tried in both Safari and Firefox on my Mac running OSX 10.11.3
I have also tried from Firefox on a Windows PC (Win 7).

Any Help or suggestions?

Same here (Windows 10).

However, when I went to add the link again, it prompted to be authorised and on accepting that it instantly worked without any other errors.

Tenebrous - thanks for the reply. Glad yours worked but I’m still getting the 500 Internal Server Error.

Hi @mtarmour, Are you able to login / access files via your onedrive url? Also can you send us a diagnostic? A 500 error is usually an issue on the server side (which often clear up over a short period of time) but perhaps we can garner a bit more information from the logs. Thanks!

Eric -

I can access everything fine with my OneDrive for business URL and client.

The error crops up with I try to add OneDrive for business to my odrive portal via a web browser.

My OneDrive for Business is through GoDaddy’s Office 365 implementation if that helps.

If you can send me instructions on how to grab a diagnostic - I will be more than happy to share.

Hello, you can send the diagnostic by clicking on the odrive system tray icon > Send Diagnostics.Are you able to access your OneDrive Business account via the odrive web interface as well?

Eric -

no - that’s the problem. When I try to add my OneDrive for business link I get the error.
I get all the way through entering my credentials and then I get the 500 error.

So - with my OneDrive for business space not even added to my account - will sending system diagnostics from the system tray icon even be useful?

The error happens when you are on the odrive website adding OneDrive Business as an account. When it tries to authorise with your MS account you get the error. It does look to be an error on MS side though.

I have seen that MS can be very frustrating when you have multiple account types and things get confused between the different accounts.

@mtarmour Can you try logging out of all MS accounts via MS’s web applications, then linking your OD4B account again? If it still fails, please tell me the precise time that you submitted the link request. We can see if there is anything in the logs re: this.

Tony -

I signed out of the OneDrive app on both my Mac and my work PC as well as my iPhone and iPad.

I just now tried to add OneDrive for business (11:20am MST) from FireFox on my Mac and receved the 500 error before even getting to a authentication screen.

Thinking there may be a caching problem - I opened a fresh browser instance (Safari this time) and tried to add my OneDrive for Business (11:23am MST) and got to an authentication screen, entered my credentials, and then received the 500 error again.

Thanks. Can you also provide a screenshot of the error you are seeing?

it is only text: 500 Internal Server Error. The server has either erred or is incapable of performing the requested operation.

Thanks. I found a trail. I’m following it now.

@tony - any update on this?

We found an issue. Actually, an unexpected return from Microsoft that we need to handle. The fix should be in soon, but it may not get you closer to linking because OD4B is not returning the needed info to connect. I am going reach out to Microsoft about it.

Good Morning. I haven’t seen any updates on this so I thought I would try to add my OneDrive for business space again. While it does not error out - it still does not add to my odrive account. I goes all the way through the authorization process and still nothing. I even tried removing my personal OneDrive to see if that was the error. I tried to add my OneDrive for Business account with firefox and safari with no success.

There are two issues regarding linking that we are currently working with Microsoft on. The causes are still unclear, but they are looking into it.

Hi Tony,

what is the status on this thread as I seem to be getting the same issue with Office 365 through Go Daddy when I try to connect it to odrive it doesn’t work.


Hi Max,
Can you try linking again and then tell me the specific time it was attempted? I will see if I can pull anything out of the logs.


I just tried it at 2:46 pm EST