Windows 7 Tray Icon disappears

I have Windows 7 and running version 5914 of Odrive and every now and then when I look at the task tray, the Odrive icon is gone and cannot be found in the Notification Area Icons.
I notice that the process is still running in task manager but the only way to get the icon back is to end the process and restart Odrive.

Any ideas?

Me also !
I found it’s in a empty space, still in taskbar

Can you guys open a command prompt on your systems and run this command?

powershell -command "&{Get-WinEvent -LogName application | where { $_.message -match 'odrive'} | Format-List;}" > "%userprofile%\Desktop\odrive_event_log.txt"

This will list any application events for odrive in a file called "odrive_event_log.txt on your Desktop. We might be able to catch something there that explains why the tray app is exiting.

Ok Tony, I ran your command and have the file. How do I get it to you?


I’m having this same issue as of some time in the last few days - I’m on Windows 10. It persists past a reboot - I no longer have an odrive tray icon, and have no other way to interact with my configuration, see status of whether or not it’s working, empty the recycle bin, etc. I’m a Premium subscriber if that matters.

I ran the command Tony recommended, the file produced was empty.

I do see two odrive processes running - “odrive (32 bit)” and “odriveapp.exe (32 bit)”.

I did just test and verify that it appears to be working (I added a file to my odrive and it was uploaded to the appropriate cloud drive location, and I saw the file icons change (locally within my odrive folder) to indicate the sync status.

I’ve never been a fan of having the tray app and its pop-up menu be the only way to view odrive status and make configuration changes - but I don’t even have that at the moment :slight_smile:

Hi @bobdunkle246,
You should be able to attach it to your response here, or you can message me directly.

The process for the odrive tray menu is odrive.exe. It runs out of the .odrive bin directory. Are the folks who are seeing this still seeing the odrive.exe process in task manager after the icon disappears from the tray?

HI Tony

Just saw my icon is gone again and I went into Task Manager/Processes and there is no Odrive.exe. There is however an odriveapp.exe *32

Thanks. I received your direct message and we are taking a look.

While we are investigating this, I just want to let people know that you can get the tray menu back without restarting odrive by running the odrive.exe app in our bin directory. Here is a command you can run from a command prompt to do it.

powershell -command "&{$bin=$(ls -Dir \"$HOME\.odrive\bin\" | sort Name -desc | select -f 1).FullName; Start-Process -NoNewWindow \"$($bin)\odrive.exe\";}"

HI Tony

I was just wondering if you fixed this issue because I haven’t lost my icon for days now? It use to go away at least twice a day.


Hi @bobdunkle246,
We haven’t released a fix specifically for this, but it may be possible that a recent Windows update adjusted some behavior that mitigated the issue.

In any case, I am glad you are no longer seeing it :slight_smile:

Hi Tony

Just to let you know, since Odrive updated, the icon now disappears again.


Hi @bobdunkle246,
I took a look, and we didn’t change anything that touches these areas of the code, so a new update, in and of itself, shouldn’t have affected this.

When you get a chance, can you run this command again and send me the output? I just want to see if there are similarities in the results.