Windows 10 Sync does not work

Right click on Sync, nothing happens. No message, .cloudf link does not change to folder. Happens for folders and files. Build 6470, happened with previous build too (6464 I think). Tried rebooting. No obvious error messages in system tray. I can however double click on .cloudf link in explorer and the individual file or folder will sync. This workaround doesn’t let me do sub-folders/files.

Hi @fezmatic,
Did the context menus show up in the past? If so, when did they start failing?

Are you seeing the icon overlays (badging of files and folders), or are those missing too?

Some things to look at/try:

  • Have you tried an uninstall and reinstall of the odrive client? This could possibly resolve the issue.

  • The context menus and overlays do require the shell extensions to be able to communicate to the odrive client over local ports. This means that anti-virus/firewall/endpoint protection software can block communication and prevent these options from being seen. Do you have any of these types of applications running in the background? If so, can you try temporarily disabling them to see if the behavior changes?

  • Do you have any other applications that provide context menus or icon badging in Explorer? if so, you can try uninstall those, at least temporarily, to see if the behavior changes.

  • Try creating a new Windows user, logging out of the existing user account, and logging in with the new Windows user. Any change?

  • There was a case a couple of months ago where a user could not see the context menus, but was able to correct the issue by ensuring that the Microsoft .NET Framework 3.5 was turned on in Windows Features. odrive doesn’t actually require this, but it is possible that turning this on corrected some other, related environment issue.