Window 10 Sync to Amazon Cloud Stopped Working, Free Version

I am simply using odrive to back up photographs on a .5TB SSD drive to Amazon Cloud. Unfortunately, it stopped syncing a couple weeks ago. odriveapp.exe is running but it does nothing but notify me after I delete a file. New files are not being synced to the cloud. odrive just sits there using 0% CPU 0% disk, and 0% network.

Sync is not paused. I am running Norton Security but looking at its logs, I see nothing related to blocking odrive.

I have tried this, all it does is spit out the folder name and goes into an idle state:

Microsoft Windows [Version 10.0.10586]
© 2015 Microsoft Corporation. All rights reserved.

C:\Users\Gerry>cd “%userprofile%.odrive\bin” && dir
05/07/2016 08:28 PM 5302


I’ve got a few questions for you:

  1. Can you go to the tray menu and select Send Diagnostics (reply so we know you’ve done it so we can keep an eye out for it)?
  2. Is this a problem only with your Amazon Cloud Drive account as a linked source? Do you have other sources you can link and test?
  3. How are you accomplishing your backup operation? Are you dragging new files into the Amazon Cloud Drive link folder in your main odrive folder (e.g. %userprofile%\odrive\Amazon Cloud Drive)? Or did you right-click on a folder outside of the odrive folder and select Sync to set up a direct sync relationship (a premium feature which you might have used while on a free trial of premium)? Please provide a step-by-step description of what you did, if you can.
  4. Can you remove the new files that haven’t synced to the cloud and put them somewhere for safekeeping (make sure you get them all) --> go to the tray menu and select “Manage links” --> unlink Amazon Cloud Drive --> relink it? See if that fixes the problem?


Sorry, since I couldn’t find a way to debug the problem - no meaningful console output, no log file, no “-debug” switch on the command line or anything at all and it was a Sunday (Mother’s Day), I decided to try GoodSync’s beta Amazon Cloud interface and it works fine, despite its clunky and old-fashioned UI.

I have since uninstalled odrive - it worked great for six weeks, and for free! Thank you.

I did find that the timestamps on the files uploaded to my Amazon Cloud drive by odrive were ahead of the timestamps on my hard drive. That gave me slight diffficulty getting them synchronized without re-copying all the files. You may want to look into this. Most file synchronization programs go to great extent to see that timestamps are synchronized.


ACD doesn’t support setting modtime to local disk. odrive works around this by using a custom property to maintain the local modtime, but this is not available if you don’t use odrive.

Thanks for trying odrive! We have many new features in the works. You might find a reason to come back to odrive in the near future so stay tuned.


Wow! I work as a developer with S3 frequently (we add & delete 2-3 million MP4s on it daily) but, personally, I find the ACD user interface quite lame. ACD’s API, which I don’t know, must be equally as lame. Why they take a Ferrari (S3) engine & chassis and put a Corolla body on top is beyond my comprehension.

I do plan to keep an eye on odrive.