Unable to unsync on MacOS 10.13 (High Sierra). No permission

Hey guys,

I’m having a problem with the syncing/unsyncing of files from my Dropbox. Might not really tell you much but I’ve attached a screenshot.

I’ve recently updated to High Sierra and also ran a pretty hefty scan/clean with Clean my Mac 3. Not sure if this has compounded my problems.

Thanks in advance,
Stu W.

Hi @SaucyWeeTart,
This generally indicates a filesystem permissions issue. odrive is trying to delete the local file/folder and replace it with a placeholder, but MacOS isn’t allowing it.

In the past I have seen that this can be due to a few things, ranging from obscure ACLs on the files/folders to another application setting the files to read-only.

Are you seeing this on all files and folders, or only specific ones?
In the case above, it looks like it is having an issue unsyncing a folder way down in the structure. Can you drill into that location and try unsyncing items directly?
Can you also send a diagnostic from the odrive menu after this occurs?

Hi @Tony

Thanks for the reply. I actually have tried unsyncing from various levels in the tree (right down to where it ends) and the issue still persists.

Unfortunatly, I’m now having a different issue. Not to derail the thread, but can you help me out with it? It’s regarding my subscription and it’s now saying that the unsync feature is reserved for premium users - which I am.

Any thoughts?

Hi @SaucyWeeTart,
Make sure that you are logged into the correct odrive account. This can happen if you ended up logging into odrive with different authentication provider than the one you signed-up with.

You can double-check this by looking at the user listed under “Authorized User” in the odrive menu on your desktop. Make sure this matches the user with the subscription in the odrive web client. The places you want to look are:

The information on the profile page should match the information under “Authorized User” in the odrive menu.

I’m confused. They seem to be the same, but still no joy.

Hi @Tony,

Scratch that last message, I’ve sorted it out. Working out what accounts are using other account can sometimes be a pain in the a**.

Thanks for your help.

Hi @SaucyWeeTart,
Great! I removed the images from your post, just in case you didn’t want your e-mail posted here.

Is unsync working as expected now too?

It’s a bit hit and miss to be honest. Sometimes certain things work and other times, they doesn’t. For instance, the oDrive choices in the contexual menus are sometimes not there. Also, the little placeholder file markers are all over the place in terms of telling you what files are synced or unsynced. A bit unpredictable.

All in all, oDrive in High Sierra seems to be really ‘janky’, for a lack of a better term. I’ve been testing it on a fresh install of OSX, too.


Hi @SaucyWeeTart,
We just released a new version for High Sierra late last night. It should’ve auto-updated by now. Badging and context menus should be a lot better now.

Are you still seeing the issues?
Context menus and badging can be a little erratic if there is a lot of activity going on, or bulk processing (mass imports or downloads)

Hi @Tony,

I use it all the time but never really do anything to erratic with it because I’m aware that it can flake out.

Yep, the badging is still pretty much non-existent for me. I take it that ‘prod 6344’ is the newest release?

Hi @SaucyWeeTart,
That is correct. When you get a chance, can you try a system reboot? 10.13 added some additional constraints on the Finder extensions and it may take a reboot to get all of the old stuff cleared out and the new stuff loaded.

If you still see the issue after that, can you send a diagnostic from the odrive menu?

Hi @Tony,

I’ve had multiple reboots (including an entire reformat of my MacBook) and the problems seem to persist.

I’ve just sent a diagnostics report.


Hi @SaucyWeeTart,
I took a look at the diagnostic and things seem to be in order from that perspective. odrive appears to be functioning normally, scanning and syncing. The Finder extension is a separate process that I can’t relaly get visibility into, but it talks to the main odrive process.

Just to make sure, you rebooted your system after the 6344 install? This may have come in as an autoupdate after you had done all of your system work, so I just want to double-check that.

Are you able to describe the behavior you are currently seeing? It sounds like you have some unexpected badging. Can you provide a screenshot of that?
Are you still seeing that right-click menus are not showing up where they should be? Can you send a screenshot of that too, when you get a chance?

Hey @Tony,

Sorry for the delay there, I totally missed your reply.

I have indeed rebooted my system multiple times after the 6344 install. In terms of functionality, things seems to be alright at the moment - i.e files are syncing/unsyncing just fine. The badging seems to be the ongoing issue.

For instance, the badges sometimes don’t reflect current progress properly. It’s seems to turn from no badge to the blue checkmark badge without the pink ‘loading’ badge in between.

In this screenshot for instance, I know that some of these files are currently syncing, but I can’t tell from the badging:

What it’s missing is this:


As I say, it’s only sometimes this happens and I can’t really place my finger on when it is. It has got much more reliable since my first post in this thread, but I don’t know why.

Stu W.

Hi @SaucyWeeTart,
In this screenshot the highlighted file is actively syncing? The pink badge will only show if a file is in the process of transferring, so even it its in the queue, it won’t show until data is moving across the network.

If it is definitely currently transferring but not showing the pink badge, does it show the badge if you toggle the odrive Finder extension in System Preferences->Extensions?

Hi @Tony,

Yep, I’m aware of that. The files in the screenshot was the total number of files that I moved into my test folder so there was not extra files within that folder (out of view) which were actively syncing whilst I was taking a screenshot of the ones that wern’t. The files basically changed from an ‘unsynced’ to ‘synced’ state without being able to track what was being actively synced.

As I say, it happens much less than before, and personally not a huge problem, but thought you would want to know regardless.

Stu W.

Thanks for the info @SaucyWeeTart. I have passed this info on to QA to see if they can repro so we can further investigate and try to smooth out the experience.

Even if the transferring badge cannot be seen, do you see the active files listed as syncing in the odrive menu?