Unable to Sync Google Drive.cloudf

I have been using using Odrive for a couple month with good results with Dropbox and Google Drive. I recently made a switch from a Mac to a Windows 10 work computer. Since I made that switch, I’ve been unable to sync Odrive with Google Drive. Dropbox has worked perfectly. When trying to sync Google Drive, I get the message in the attached image. I’ve read others solved similar issues by having their Google Apps admin change a setting regarding the API for third party apps. That’s a possibly the problem for me. But I’ve tried this with both the work account and my personal with no difference. Please let me know if you have any insight. Thanks.

Hi @pmarston,
Are you still able to access that account from your Mac?
Are you able to browse it from the odrive web client? (https://www.odrive.com)

If so, it’s possible its hitting some sort of illegal character in the root of that drive. Can you take a screenshot of what the root of the drive looks like from the odrive web client so I can take a look. Also, please send a diagnostic from the odrive tray menu after reproducing this error.