Unable to sync delete [file name]. Please check your network connection or manage your proxy settings

I get the above error when trying to empty my “trash bin.” I use Amazon storage. I tried rebooting, but that was no help.
So now I just tried to “Send diagnostic”, but I got the error “There was an error sending the diagnostic report.”
Please help.

Hi @mbarre2004,
Can you make sure you have the latest odrive version installed? We released a new version last week and have not pushed it out to the autoupdater yet. https://docs.odrive.com/docs#section-download-and-run-installer-

After installing the latest version, try to reproduce the issue and then send a diagnostic from the odrive tray menu. This will also create a file called “current_odrive_status.txt” in the root of the odrive folder. Can you message that file to me, as well?

From Windows 8.1 control panel, it seems my current version number is 1.0.6083.
Is there an easier way to check that (e.g., from the tray)?
And which version is latest, please?
And do I uninstall the current version first, or just install the latest on top?

Hi @mbarre2004,
The version you see in the control panel is the last “full install” you did, which doesn’t necessarily represent the version you are running, since we autoupdate. The easiest way to check the version is from the odrive tray menu. It will be listed right above the “Send diagnostics” option.

We actually just pushed out the new version via autoupdate, so you may have the latest now, which is 6480. If not, you should be getting it soon.

Thanks. I am at 6480 now. And I was able to send diagnostics.
How do I send you the other file you requested?

Hi @mbarre2004,
I was able to look at the diagnostic. It looks like you are occasionally hitting some network errors when running the empty trash routine.

Are you hitting this error immediately, or does it seems like some items are processed before seeing the error?

If you go to the odrive trash, click on one of the items listed there, and select “Sync delete”, does it produce an error too?

It seems like sometimes it stops on the first one, and sometime it processes a few first. Maybe some more files got added to the list, and it was able to delete some of those. Not sure.

Anyway, when I click Odrive in the tray and mouse-over “trash bin”, I see a list of 88 files under the heading “click to recover”, and an option at the top to sync all deletes. I don’t see an option to “sync delete” a single file.

Edit: I clicked a file under “click to recover”, and then an option to Sync Delete popped up. So I chose that option, and it worked.

Then I had 87 filed in the trash bin. So I clicked Sync All Deletes, and it deleted 11, and then failed again.

Then I tried to sync delete the file at the top of the list, and it failed.

Hi @mbarre2004,
It looks like there there is some instability in the connection that is causing fragility with all of the requests. It sounds like we just need to power through the trash emptying process, restarting after it hits these network errors. This method is a little advanced, but I will try to walk you through it.

  1. Open up a command prompt window by clicking on the Windows icon in the taskbar, typing “cmd”, and then clicking on “Command Prompt”.

  2. Once the command window is up, we will use it to download the odrive CLI. This command will install the CLI, which allows us access to more advanced functionality. It could take a minute or two for this command to complete:

    a. Highlight and right-click->copy the following command (all one line):

    powershell -command "& {$comm_bin=\"$HOME\.odrive\common\bin\";$o_cli_bin=\"$comm_bin\odrive.exe\";(New-Object System.Net.WebClient).DownloadFile(\"https://dl.odrive.com/odrivecli-win\", \"$comm_bin\oc.zip\");$shl=new-object -com shell.application; $shl.namespace(\"$comm_bin\").copyhere($shl.namespace(\"$comm_bin\oc.zip\").items(),0x10);del \"$comm_bin\oc.zip\";}"

    b. Right-click inside the command prompt window to paste your copied command.

    c. Hit the return/enter key on the keyboard to run the pasted command.

  3. This next command will push through any errors and continue trying to empty the trash until it is done:

    a. Highlight and right-click->copy the following command (all one line), just like you did on the previous command:

    powershell -command "& {$comm_bin=\"$HOME\.odrive\common\bin\";$o_cli_bin=\"$comm_bin\odrive.exe\";while ($(& \"$o_cli_bin\" status --trash) -ne 'No trash.') { echo \"There are items in the trash. Emptying...\";& \"$o_cli_bin\" emptytrash;sleep 2};echo \"Trash fully emptied!\";}"

    b. Right-click inside the command prompt window to paste your copied command.

    c. Hit the enter return/key on the keyboard to run the pasted command.

Thanks. Unfortunately, after step 2.c. I got some errors.
I could send you a screenshot, if there was a way to attach a file, but the first started with the following (but ignore [z], which i added to prevent this interface from adding a bullet point):

exception calling “downloadfile” with “2” arguments: “The request was aborted” Could not create ssl/tls secure channel."
At line:1 char:75
[z]+ &

Edit: Also, now when I click on Odrive in the tray, the interface (with options like “trash bin” etc.) does not pop up. Which is another problem I’ve been ignoring for a while. I’ll reboot, and that problem should go away, at least for a while.

Edit 2: I powered through using Odrive from the task bar, and my trash bin is now empty, after at least a dozen more failures.

Hi @mbarre2004,
Thanks for the update and trying those steps!

I’m glad you were able to get through the trash processes.

The error you hit with the script looks like another network-based error, similar to what odrive is hitting. Is there anything of note about your internet connection? Have you been seeing any issues with it, in general, lately? Do you have anything in place that could be in the middle of the connection and causing some issues?

For future reference, you can upload items to your using the icon on the message toolbar:

This is odd. So the icon is there, but clicking on it doesn’t do anything?

No other problems that I’m aware of, connection-wise. For instance, I have no trouble playing League Of Legends (except for my terrible skillz).
And yes, the odrive icon is in the tray, but clicking on it does not do anything, as far as I can tell. Then rebooting fixes it for a while. For instance, it is working now.

Hi @mbarre2004,
Thanks for the additional information. I will circle back with the team to see if there is anything else we can do to compensate for network errors like these.