Unable to Open Amazon S3 Bucket with Windows Client

Hi all,

Loving oDrive, however, i’m encountering problems with it. I can link my Amazon S3 bucket just fine and access the files via the oDrive Web Interface, however, when I attempt to access them via the Windows Client I am unable to do so:

Image Showing Amazon S3 Bucket Error

Hi There,

Can you make sure that the app is not being blocked by anti virus and/or firewall settings? This is typically the issue when you can access your files via web but not on the desktop client. Another quick question; are you able to link and access other services such as Google Drive?

It’s not AntiVirus/Firewall, I can assure you of that. I also am able to easily link and utilize other services, including other Amazon Services that work just fine. Just not the Amazon S3 Bucket.

Thanks! Would you mind shooting over a diagnostic so we can take a look?

Yes sir, done :). Thank you very much for helping me out btw. I signed up for the Pro Sync just to see if that would improve it but sadly so far no luck. Though i’m happy to keep the Pro Sync as you guys have given me what i’ve been looking for, for years!

Perfect! I’ve passed it along to engineering for review, and will follow up as soon as they get back to me. Thanks for your patience while we work through this.

Hi There! I just wanted to let you know we kicked off an update that can be downloaded from https://www.odrive.com/download

Can you try installing that and let me know if it resolves the S3 issue you were experiencing? If not would you be so kind as to shoot off another diagnostic? Unfortunately we have not been able to reproduce in house so any help we can get would be very much appreciated!

Hi @WKelley,
If the update does not resolve this, can you reproduce the issue (double-click the S3 folder) and then immediately kick off a diagnostic?

We really want to get to the bottom of this one.

I have exactly the same issue from both Windows and OSX … and I’ve tried from different network locations … so no firewall, etc. issues. I can access my Amazon S3 bucket from other software (e.g. Goodsync), no problem. Would really be nice to get this working …

Hi @Brad_Gault,
Can you produce the error you are seeing and then immediately click on “send diagnostics” from the odrive tray menu? Ping here when you have done so.


Diagnostics sent … thanks !

Thank you @Brad_Gault!

Hi Brad,
I haven’t forgotten about this. We are trying to see if we can gather more info on this to determine what is happening.

I’m having the same problem - is there any resolution yet? I tried without my anti-virus on and it didn’t help. Diagnostics sent…


Weird. I connected odrive to S3 buckets some time ago with no problems. Those still work. If I try connecting to new ones I have the same problems as listed above. Something broke…

We aren’t able to reproduce this issue (our buckets link just fine). Is this using S3 enhanced or standard?

Just to be clear, you are able to browse via the web client but not the Desktop?

Standard … (but I think I have tried both with the same result) …

oh … and yes … can browse just fine with the web client but not the desktop …

Can you provide a screenshot of the root directory from the web app? Also can you provide the bucket name being linked to? You can PM me directory if you do not want to post in here.

I am wondering if there is something strange in the listing or the bucket name that is causing issues on the desktop.