Trouble installing latest release

odrive_20160826100545.log (8.6 KB)

I am having trouble installing the latest release. (Getting a fatal error 0x80070643.) Using Windows 10 on a Surface Book. (Log file is attached.)

Hi @Jeremy,
I’m taking a look at this.

Is the install presenting you with any error messages? If so, can you take a screenshot?

This error:
[1EF4:1EEC][2016-08-26T10:05:52]e000: Error 0x80070003: Failed to get size of pseudo bundle: C:\ProgramData\Package Cache{4cee5fcc-e7ca-49d6-9118-68676150dba0}\odrive.exe
[1EF4:1EEC][2016-08-26T10:05:52]e000: Error 0x80070003: Failed to initialize package from related bundle id: {4cee5fcc-e7ca-49d6-9118-68676150dba0}

Indicates that there is a previous version of odrive installed, but the upgrade installer cannot access the package cache properly. This may not be the reason for failure though. Do you know if you ever cleared anything from C:\ProgramData\Package Cache?

Can you also see if there are any other logfiles with the one you posted? Generally there will be 2-3 that are created during install. They all begin with “odrive” and will be in the “%userprofile%\AppData\Local\Temp” folder. If you sort by “Date modified” they should be towards the top.

I cleared the Program Data and Temp folders. Then ran the
install again. Here are the screen shots (in order) and the error files.

odrive_20160826125825_000_Odrive_x64.exe.log (73.1 KB)
odrive_20160826125825.log (10.6 KB)

Hi @Jeremy,
You mentioned above that you “cleared the Program Data” folder. Was this the C:\ProgramData folder? You don’t want to delete anything in this folder as it is needed for installation/upgrade of the applications on your system.

It is fairly common for folks to want to clear this out to free up disk space (a ton can be taken up in there over time). Unfortunately doing this really hoses the installation of things. If this is the case we will need to try to restore it.

Do you have any system restore points that can be restored from?

Alternatively, you can see if there is a previous version of programdata that can be restored:

  1. Right click on Program data folder and click on properties
  2. Click on Previous Version tab
  3. Select the date when you have made changes in the list
  4. Click on Restore button and click on OK.

Otherwise, you can see if the files are still in your recycle bin.

Let me know what you find.

Sorry, to be more specific, I cleared the ProgramData/Package Cache folder. This was after having the problems with the install, so isn’t the cause of the problem. Just an attempted fix. (It didn’t help.)

Hi Jeremy,
If you are able to restore the Package Cache, please do so. It will actually create more problems if that is purged.

If you are not able to restore it, can you see if you are able to uninstall odrive and then reinstall?

I made a copy of the folder, so restoring should not be a problem.

I am worried that if I uninstall the existing version and the install of the old version fails, I will be stuck with no odrive. (perish the thought.)

K let’s try this first:
Restore the Package Cache
Try the install again and take a look at the paths that are referenced in the errors. Do they actually exist?

What is happening is the installer is looking for the package cache for the previously installed version and it freaks because it either can’t find it, or can’t access the folder properly.

Can you also tell me what version is listed as installed when you go to the add/remove programs section (where you would go if you wanted to uninstall)?

Please update here with what you find and we’ll see if there is a way to work around it.


No, the folder does not exist.

The version is 5453.

FYI, there was a major Windows update a few weeks ago–don’t know if this might explain the missing folder…

I extracted the relevant files for the package cache. The cache is in two folders. Each will have a unique name, specific to your machine. You will need to create the missing folders then drop the relevant files in.

You can grab the files for v5453 here. I’ve grouped them accordinly:

I tried creating the missing folders. I am still getting the same error message.

Is there a way to just try a clean (re) install?

Unfortunately, once you are in this state you can’t uninstall or upgrade. It sucks, but it’s the way Microsoft designed it.

You could try this utility and see if it offers any solution:

So you created the folders and put the files it was looking for in there and it still says it can’t find them?

Are the errors exactly the same? Can you send over the install logs from the new run?

Yep–I was getting the same errors.

I tried the troubleshooter–I picked the option to uninstall. (It reported corrupt registry keys.) Then reinstalled and everything works. :slight_smile:

I was thinking I would need to do a clean install of windows so this is a big time saver. Thanks!

1 Like