This file doesn't exist

mac

#1

Hi. I’m using Odrive on a Mac. I have several accounts linked up. Recently, the sync has been acting strange. I keep getting the error message:

Unable to sync [FILE NAME}.cloud.

This file doesn’t exist.

These are all files that do exist.

I’ve tried unlinking and relinking the account. I also tried the suggestion on another thread of quitting odrive, moving the root folder, unlinking, relinking, opening odrive again, moving the root folder back.

Nothing seems to be working. Occasionally, I’ll have the option to sync a file, but not often.


#2

Hi @creaturesfarley,
This is happening when you double-click on a cloud file, right-click->sync a file, or both.

This can sometimes happen if odrive is overly-busy performing background processing, but it shouldn’t happen too often.

Can you reproduce the issue a few times and then send a diagnostic from the odrive menu so I can take a closer look?


#3

Hi Tony

I’ve recreated the issue several times. I actually then went and unlinked my Box account (the one that seemed to be causing the issues) to try and unsync everything with the aim of syncing back up for a fresh start.

Now, although I can see Box in the web client, it’s not showing as ghost folder option on the desktop.

Additionally, none of my other accounts are now syncing either - all of them come up with the same “Can’t sync X, the file doesn’t exist” error message.

A little unsure how to proceed…


#4

Updating to let you know I went through a full uninstall from another thread using the Mac OS terminal command. I re-downloaded the desktop sync client and signed in, and so faaaar, so good! It seems to be behaving itself.


#5

Thanks for the update @creaturesfarley!

I took a look at the diagnostic and it looks like there was an inconsistency with the local tracking database that was causing some issues. This can happen (although rarely) if the app is exited forcefully, the system shuts down unexpectedly (sudden loss of power or hard restart), drive issues, etc.

My recommendation would’ve been to reinstall, but you’ve already done that :slight_smile:

I’m glad to hear things are back on track now.