Syncing all files when I don't want it to

Hey guys, first post here.

I’m using oDrive because I’ve limited storage on my new computer. I’ve got a problem though. Every time I go to access my Dropbox folder, the WHOLE folder seemingly starts to download. I’m not sure if I’m understanding it properly, but what I’m trying to achieve is:

  • Open oDrive folder
  • See ‘’ folder’
  • Double click said folder (and folders within) to view my files and not download them

I can only assume that it is auto downloading files/folders as I open them, as my local storage starts getting swallowed up straight away. I’ve tried turning off auto-download in the menu, but the behaviour seems to remain every time I restart oDrive.

Can anyone help?

Thanks in advance,
Stu W.

Hi @swilkie1983,
When you right-click on the Dropbox folder and select “sync”, are there options set on the sync pop-up window to download? If so, what are they set too? Providing a screenshot may work best.

Also, just to be clear, “Set auto download” in they tray is set to “Never Download (currrent)”?

Hi, I took a couple of screenshots to try and clarify.

So first I see the ‘Dropbox.cloudf’ file, then I double click it to open it and view it’s contents.


Without me clicking on anything else, oDrive starts auto downloading the files/folders in my Dropbox.


…continued on next post because of the 2 post limit >

The files/folders it auto downloads inevitably take up local disk space, which I don’t want. I want to view the files/folders and individually select the ones I want to download onto my local disk, not to download them all because I don’t have the space.


As per your last suggestion, I’ve tinkered about in the settings, but nothing seems to work. Like firstly stopping ‘automatic sync’.


…continued on next post because of the 2 post limit >

I’ve also disabled ‘auto download’.


That’s about it. I’ve tried every combination of restarting my laptop/oDrive, and nothing seems to be working. Not sure if I’m missing something obvious…

Thanks again,
Stu W.

Hi @swilkie1983,
Did you check the right-click->sync options that are set. Take a look at this post, which may apply to your case:

In your case, step #1 would be right-clicking on your Dropbox folder instead of the odrive folder.

You can read more on folder sync rules in our usage guide:

Make sure to pay special attention to the right-click>sync menu. You will want your right-click->sync settings on the Dropbox folder to look like this:

2 posts were split to a new topic: E-mail shown in profile?

I am on a Win 10 machine. Odrive v6052.
I have this issue too. I was pretty sure that in the past when you navigated into the folders and expanded the folders, the files/subfolders will be expanded as per the global setting, in my case “Never Download”, so I would get placeholder files. Now when I navigate into folders and expand them, Odrive starts to download all the files.

Yes the individual folder setting (right click) is set to “Download everything”, but previously that was only used when you wanted to perform a sync using the Right-Click function, and not just navigating and expanded folders.

What is now the use of the Global setting if Odrive will always honour the individial folder setting.

Without changing the individual folder setting, is there anyway to navigate the folder structure and expand the folders and see just placeholder files.


Hi @maccra,
The individual folder sync rules override the global setting. If it was the other way then the individual folder rules wouldn’t have any effect because the global rule would always be used.

Keep in mind that folder sync rules are only created when you check the “Save and apply to new files and folders” checkbox. This indicates that you are creating a rule that will be applied, going forward. More on that here:

If that checkbox is not checked on the current folder, or any of its parents that had checked “Include subfolders” then the global auto download rule will apply when you expand the folder.

With nested structures the rules can get complex. Remember that folders can inherit the settings of their parents, if the appropriate boxes were checked.

Hi @Tony
Thanks for the explanation again. I read the Usage Guide and I understood the syncing as per my description.
However I remember now that where I wrote above, “In the past…” , I was remembering how ituse to work in the free version. As you know in the free versionyou can not save the folder settings, so everytime you expanded a folder it would follow the global settings. Now with the premium version expanding the folder follows the folder settings. That was not clear to me before or even clear to me in the Usage Guide.

In the premium version, the global setting only comes into play if you have not “saved” the folder settings?


Exactly. In the absence of folder-specific rules, global rules are used.

Hi Tony,

So currently I have a master folder which has loads of nested files and folders within. Am I right in thinking that if I change the individual folder settings to the master, then all others files down the tree will be affected by the same rule?


Hi @swilkie1983,
To apply a folder sync rule to the master and all underlying folders:
Right-click->sync the master folder, select your desired download threshold, and check both checkboxes.

To remove folder sync rules on all of the underlying folders, so that they follow the global auto download setting:
Right-click->sync the master folder, uncheck “Include subfolders”, and check “Save and apply to new files and folders”.
In this case the slider setting doesn’t matter too much, other than setting a default for subsequent right-click->sync actions.

For those like me that happen upon this while freaking out a couple points need adding here:
Doing the right click sync with subfolders checked will create all the sub folders no currently synced and fill them with .cloud link files making appear is still downloading everything.

My setup seemed to be working fine till I changed my bandwidth limits. That seemed to trigger an override of the “download never” global setting. Which in turn started repeated warnings about unsynced old files. The only way I got it to stop trying to download everything below the active root folder was to use the above right-click to set that folder and subs to download never.

Hi @dea_amazon ,
Can you clarify what you mean by “till I changed my bandwidth limits”? I just want to make sure that the behavior you saw is expected and not something that needs to be addressed.

Also, when you send a diagnostic, a local file is created in the root of the odrive folder named “current_odrive_status.txt”. This has nitty-gritty details about odrive configuration and includes all of the currently defined folder sync rules along with any global rules defined.