Synced folders not showing up on Desktop Client

Update: Issue seems to have been related to fact that certain folders (non-odrive related) under my User directory were set to Hidden. After unhiding everything, the sync seems to be working fine.

Hello everyone, new odrive user trying to setup for the first time. I’m running into some issues with he desktop client and was hoping for some help.

Here’s what I’ve done so far.

  • Setup odrive account
  • Linked Google Drive via web client
  • Downloaded odrive desktop client (Windows 10 Pro, Build 18362)
  • Installed odrive desktop client

Here are the issues I’m running into

  • The desktop client does not show any of my synced folders
  • The only files in the odrive folder are odrive_user_general_conf and odrive_user_premium_conf - nothing else
  • In the taskbar menu for odrive, the Open odrive folder option says [missing] next to it. When I click it, a window saying “Invalid odrive folder - odrive could not be synced” pops up and allows me to change the folder’s location. When I do so, nothing happens and it still shows as [missing].
  • odrive seems to be creating multiple instances of the program (Welcome to odrive window will randomly popup, sometimes have 2-3 odriveapp processes running in the background)
  • Minor issue: when I attempt to log into odrive on the web client using my Google account, I have to re-authorize access each time
  • Minor issue: the “Welcome to odrive” popup appears twice when I setup the desktop client

Here’s what I’ve tried

  • Uninstalling Drive & Dropbox and moving the folders somewhere besides my user directory
  • Uninstalling odrive, restarting PC, and reinstalling odrive (done twice already)
  • Removing odrive’s access to my Google account and re-adding it
  • Relogging on the desktop client (by deauthorizing the user and by using the repair tool on the installer)

Any advice?

Hi @shlokrshah,
My apologies for not replying sooner.

It sounds like you’ve got things worked out now, but please let me know if you are still seeing issues.

The behavior you were seeing is definitely unexpected, so I am curious as to the details of how you resolved it, if you can share.

Hi @Tony,

No problem, I actually experienced the same issue again when installing odrive on my laptop which proved my initial theory of the hidden folders wrong. I think the real problem was as follows:

  • My user folder was renamed (capitalized the first letter - no other changes). While it shouldn’t have been an issue, odrive was unable to locate the odrive folder based on the file path that it generates upon install and was giving the “Open odrive folder [missing]” error in the notification bar menu.
  • I clicked the “Open odrive folder [missing]” error which then opened a prompt asking me to identify the folder. Rather than clicking the odrive shortcut on my Windows Explorer pane, I navigated to This PC then clicked through my folders until I got to C:\Users\Admin\odrive. When I selected the odrive folder that way, the sync immediately worked.

Hi @shlokrshah,
Thanks for troubleshooting this! It sounds like we need to make sure the path used when opening the odrive folder is not case sensitive. I will add this to the list for a future release.