Synced folder greyed out on Mac

I’m having a problem using drive with my Amazon Cloud Drive on my Mac (running El Capitan). I have had no problem linking my account, installing the drive app and copying my Documents folder into odrive, which then successfully synced it with Amazon. The problem is that the resulting Documents folder (inside the Amazon Cloud Drive folder inside the odrive folder) is greyed out in Finder, and I can’t seem to do anything with it. The Amazon Cloud Drive folder is not greyed out, but the Documents folder inside it is.

Here’s the weird part. I use Forklift (an enhanced Finder) for all of my file management. And the synced Documents folder is not greyed out in Forklift–everything there works properly. I can also access the folder through the terminal and perform file management functions from the command line. But I can’t do anything with it in Finder, which means I also can’t do a “save as” or open a file from within any program. I can open files by double-clicking the filename in Forklift, and I can save an existing file under the same name within programs, so the program can successfully write to the folder. But if I go to create a new file within a program, I can’t save it to anyplace in the odrive Documents folder.

In an attempt to figure out what was going on, I created a Test folder inside the Amazon Cloud Drive folder in odrive and put a few files in it. They synced fine, and they’re accessible from Finder (and I can “save as” and open from that folder). I then tried changing the name of the Documents folder within odrive in case it was having a problem with the Documents name. That didn’t help.

I thought maybe this was a problem just while the folder was syncing, since the Documents folder is big–about 300gb–and it took several days to sync. But now, everything shows up as fully synced, and it’s still greyed out. I also restarted Finder, quit and restarted odrive and restarted the computer. None of those made a difference.

Any thoughts?



Hi Bill,
I’ve seen this happen before and usually the way to fix it is to manually set the created and modified dates on the greyed out folder from terminal using a command like this:

greyfolderpath="$HOME/odrive/Amazon Cloud Drive/Documents";SetFile -d 06/29/2016 "$greyfolderpath";SetFile -m 06/29/2016 "$greyfolderpath";

You will need to change the path to the correct one for you (I made a guess here).


Hey, that worked! I used the graphical Get Info from Finder and it showed me that the file creation date was from 1984 for some reason. So then I used SetFile -d to set it to the date when I actually created the folder and voila, it now shows up as an active folder in Finder that I can read from and write to.

Thanks very much for the help!


1 Like