Sync to odrive folders no longer syncing

I’m having the same issue. After a recent restart, Odrive no longer syncs. It worked wonderfully for the first few weeks and backed up an entire folder of many Gigs without an issue onto my Google Team Drive. I’m am using an iMac with OS 10.15.3. The “sync to odrive” option produces a greyed out “No Sync Folders Registered” tab. I have unistalled odrive, and reinstalled the latest version today. Clicking on the sync button (as per screenshot) does not trigger anything. Any ideas?

Hi @salasprojects,
I moved your post to a new thread because I think it is a bit different than the original one.

To clarify, are you seeing that new/changed files are not longer uploading, or that cloud files are not downloading?

To download, you would need to slide the slider in the image above to something other than “Nothing”.

For uploads, it should be uploading any changes automatically. The “refresh” option can be used to force a refresh of the specified folder, too.

If upload is the issue, do you see anything listed in the odrive menu under “waiting” or “not allowed”?

Can you also send a diagnostic from the odrive menu so I can take a closer look?

Thanks for your reply Tony. Yes, just interested in uploads only and I can’t get it to do this. I’ve tried deauthorising my google drive account and reauthorised it but that did not help.
The only option I get for the folder is “Sync to oDrive”. Clicking on it produces the message “Unable to sync with odrive. This is a premium feature. Please upgrade your account.” There is no option to Refresh any folder. There is a Refresh Subscription option but that doesn’t seem to do much. (screenshot)

I’ve already sent a diagnostics report but in any case, I’ve just sent another one right now along with this post. Thank you for your time on this Tony, its really appreciated.

Sorry just further to the last post:

  1. There are no new/changed files uploading any longer to Google Drive.
  2. There is nothing listed in the odrive menu under ‘waiting’ or ‘not allowed’. There is no response when selecting “Sync to Odrive”.

If you need any specific screenshots let me know.

Hi @salasprojects,
Thanks for the additional information.

Can you walk me through where you are adding the new files for upload?

  • Which folder are they going into (full path to folder).
  • Are you able to download anything inside that folder?
  • I think you are working within Team Drives, primarily, but are you able to upload new files into the root of odrive/Google Drive/? Can you try that as a test?
  • Can you add one more file into the problem folder, provide the file name, and then send another diagnostic?

What may have happened here is that you were using the “Sync to odrive” feature during the trail period. "Sync to odrive is a premium feature, so it won’t be available on free accounts after the trial has expired. The “sync to odrive” feature allows you to sync folders outside of the default odrive folder. The free version allows you to sync anything within the default odrive folder (the folder you get when you click on “open odrive folder” in the odrive menu).

More on the differences between free and Premium here: What is free vs paid (premium)?
More on sync to odrive here:

I just tried to place a file in odrive/Google Drive/ It worked!

I also put a copy of it within subfolders of Google Drive as well. That also uploads to my Google Team Drive account.

Obviously I would like it as it was before where any change in those synced folders (new files, deleted files) would be reflected in Google Drive as well. Previously, any changes would trigger the Odrive App to begin uploading.

But from what you’re explaining I need to do this manually.

So I have an external folder called “Work” that’s 50GB. If I understand correctly, I need to manually copy any changes in that “Work” folder into the “Odrive” folder for it to begin uploading it to my Google Drive account. This unfortunately would mean additional manual work and also doubling up on my hard drive’s storage space. (Previously my Odrive folder was basically 0kb)

What a shame that such a crucial feature is part of the premium version! Its a dealbreaker for me and I would need to go back to using Google’s Backup and Sync app.

Have I understood this correctly?

Hi @salasprojects,
Thanks for the additional details!

It sounds like you used the “sync to odrive” feature during the premium trial to upload all of the data in the external “Work” folder, already, so you could now work directly out of the “Work” folder that is inside the default “odrive” folder. Our free version provides the same instant, automatic syncing within the default odrive folder that you were seeing when using the “sync to odrive” feature on your external folder. Since odrive defaults to all placeholder files, you can open (download) only the files that you need so that you are not downloading all 50GB, but only a very small portion of that.

For example, I have a Google Drive that has about 500GB of data in it, but my local odrive\Google Drive folder, that I primarily work out of, only has about 250MB of local data in it, spread across a very large structure. The rest of the 499.75GB of files in there are placeholder files, which take up no space on my local disk.

As you noted, syncing external folders via the “sync to odrive” feature is a Premium feature, so you would need to purchase that to get access to it again. We do offer a 30 day, no questions asked, immediate refund for the Premium subscription if you do end up purchasing and then have second thoughts and cancel within 30 days. This means you can trial Premium for another 30 days, if you would like more time to decide if Premium or free will work for your use cases.

A post was split to a new topic: How do I stop syncing a local folder?