Sync stops every time computer reboots

I’ve set up oDrive to sync my OneDrive. It’s been working fine for a good while, but since Christmas I’ve been having problems. Whenever the computer restarts, I’m unable to get the sync going again, it seems. A couple of weeks ago I managed to get it running, though I have no idea what finally worked, but after the latest restart after Windows Updates the sync is dead again. The oDrive folder on the computer shows a green check mark, saying it’s in sync, however the online OneDrive app tells a different story; files changed are not being uploaded as they should. When I try to run a manual sync on the oDrive folder it runs fora while, the check mark changes from green to red, but eventually it fails with “Unexpected error. Please try again later.” I’m unable to get the sync going again, and I need tips as to what to do to get it going again, preferably in a way that doesn’t mean I have to babysit it every time the computer reboots.

Hi @ivara,
Can you send a diagnostic from the odrive menu so I can take a look at the configuration?

The diagnostic was just sent.

Hi @ivara,
Unfortunately it looks like the diagnostic didn’t come through properly. Can you try that again?

Can you also tell me how you have odrive setup? Is the odrive folder in the default location, or was it moved to another location?

Do you see anything listed in ‘not allowed’ or ‘waiting’ in the odrive menu?

I’ve tried to send a new report.

I’m most likely not using the default location. It’s on a RAID 5 array, named G: on the computer, full path g:\oDrive\OneDrive for the OneDrive setup. There are no “not allowed” or “waiting” items in the oDrive menu at the moment. Last time I got it working again, a few files with funny characters in their names showed up after the sync was going again, but I’ve deleted or renamed those since then.

Hi @ivara,
Unfortunately we are not receiving the diagnostic reports, for some reason. Do you happen to have a proxy or any firewall/anti-virus software running?

Are you able to download files that are currently placeholders, or does that fail too?
Is OneDrive the only storage you have linked? If not, does this happen with the other links?
When you add a new file to odrive, do you see anything happen? Is anything listed in the odrive menu during that time?

The computer does of course have anti-virus running, Microsoft Security Essentials. Windows 7 also has a basic firewall, which is running in its default state.

Interestingly downloading placeholder files and uploading new files works fine. It just does not detect changes to already uploaded files and sync the changes.

No, strike that. It detects and uploads files on the first layer of folders, i.e. directly under g:\oDrive\OneDrive, however it does not detect and upload files on any subfolder to OneDrive, nor does it detect if a new file is uploaded to one of the subfolders from another place, so it does not give a placeholder for it, and as such I don’t know if it would download OK either.

Oh, and you asked if OneDrive is the only storage I have linked; yes it is.

Hi @ivara,
This is certainly odd. I have only seen this type of issue if there were some sort of permissions problem that was preventing odrive from acting on the folders.

If you create a new folder in the root of OneDrive and then add files in there, are those synced?

We could try to reset the configuration to see if it helps. To do this, follow these steps:

  1. Choose Authorized User -> Deauthorize from the odrive menu. This will reset your odrive cache and rename the current odrive folder to odrivebackup-[current date here]. Verify that this is the case before continuing.
  2. Login to odrive. This will create a new odrive folder in your user home directory with all placeholders.
  3. Select ‘move odrive folder’ from the odrive menu and select G:\ as the destination. This will create a new odrive folder at G:\odrive. Again, this new folder will only have placeholder in it, so it should only have “OneDrive.cloudf” inside.
  4. Now move the contents of the G:\odrivebackup folder mentioned earlier, into G:\odrive. Since you only have OneDrive linked, this should just be a matter of moving that OneDrive folder from the G:\odrivebackup folder into the G:\odrive folder. The OneDrive folder will replace OneDrive.cloudf and odrive will start scanning through all of the data. If the data is the same, then odrive shoudn’t upload it again.

The scan can take a while if you have a lot of data to go through, so give it some time before trying to sync things yourself.

Also, after you do this, try to send a diagnostic and we’ll see if it comes though this time.

Choosing Deauthorize User did not rename the oDrive folder to oDrivebackup, nor did loging back in create a new one. However, doing those two steps did, for now, fix the syncing problem, and the program did a full scan and sync after logging back in. I’ve tried to send a new diagnostic after that.

Thanks for the update @ivara. I am glad to hear things are working after the reset.

Did you get the diagnostic after the reset, though? I’m not sure if this is a permanent fix or a temporary one…

Hi @ivara,
Your diagnostic still didn’t come through.

I don’t know why this is. I have only seen this behavior when there is a proxy or other type of network middle-ware that is interfering somehow.