Sync Problem - OSX Desktop / Google Drive



I have run into some problems today with odrive.

  1. Some folders are not syncing correctly with Google Drive Folders. e.g. I have one folder called PLI, in finder on my mac (inside the odrive folder) it has only one file. In the PLI folder in google drive (chrome browser) there are 8 files showing. When I log into odrive (chrome browser) I can see 8 files in this folder.

So why aren’t they showing on my desktop odrive.

I have tried deleting the folder and recreating and then re-adding the files. Also this folder is shared between two goodle drive accounts. Both accounts are in my odrive folder (on the desktop) and they are both missing the same files.

  1. When I delete a folder inside the odrive folder (on my desktop) it does not delete inside google drive (chrome browser).

Why does it not delete?

Thanks for your help in advance.


Hi @accounts1,
Can you tell me what the names of the files are that are not showing up (or take a screenshot)? Typically this type of behavior is caused by illegal characters in the file or folder names that prevent them from being created on the desktop.

For deletes, we have a feature called “odrive trash”. It is in place to prevent inadvertent deletes to the cloud. You can read more about it here:

If you want to delete the items in the cloud you just need to empty the “odrive trash”.

Hi Tony,

Thank you so much for your answer, you have solved my problems.

The trash is working, although one folder said I didn’t have permissions to delete it. I was able to delete it from the chrome browser but not from odrive in finder. Its no biggy though.

Someone had put a “/” in all the file names of the missing files!

I think it might be time for a memo about valid characters for filenames!

Thanks again for you help!


1 Like

Great! Thanks for the follow-up.

If the folder that said you didn’t have permission was a shared folder, that may be the reason for the error. If you don’t own the fie/folder you won’t be allowed to delete it. It requires removal from the Google Drive web client.